Adding a package hangs on clock-signal

I just installed manjaro on my Toughbook CF-31 and I’m having trouble installing packages. In particular, I’m trying to install printer support, but every time I attempt to download/install, I get the following error:

Synchronizing package databases…
Resolving dependencies…
Checking inter-conflicts…
Failed to prepare transaction:
target not found: clock-signal

From what I can see, clock signal is an emulator for various vintage computers, but it’s not installed on my machine. Can anyone help me get past this?
Thank You

Welcome to the forum! :wave:

For what printer? Please post the full output of the command(s) you’re running to accomplish that using preformatted text.

No idea what that is as it’s neither in the repos nor the AUR (Arch User Repository).

Please also see:

For the moment, I’m trying to install Print Settings and print-manager from the official repository. The printer type isn’t relevant because this same error prevents any packages from being installed.

which error?
We can’t see what you see.

Is there not more to it than that?

I might assume this is from an existing package and its dependencies, rather than the one you are trying to install, as pamac will attempt to upgrade before installing anything.

To easily see what is happening please perform an update in the terminal.

pamac update

Other thoughts include;

  • What ISO did you use to install? If this is a new install it is rather odd it would contain unsupported packages out of the box.

I ran the update in the terminal and it was successful. Following that, I am no longer getting the error in pamac and was able to install my printer.

Thank you!