Add/Remove software No package found in AUR

I was searching for google chrome in Add/Remove software (on Manjaro 21.1.6), I enabled AUR repositories and entered “chrome” in input line, so when I clicked on AUR button, a sign “No package found” appeared, and it was appearing everytime I searched something in AUR in Add/Remove software.
everything is working but AUR section, I reinstalled manjaro 3 or 4 times and still no progress. After 2 hours of suffering, I switched to another WiFi network (just for fun) and AUR worked!!! (all packages were shown I mean)
Idk why, but can you explain why this happens? Why can’t I find apps from Add/Remove software on my main Wifi network? and what should I do to fix this problem?

Are you using a VPN or proxy?

Either way, try installing an AUR package from the terminal on the affected WiFi network and see what the output is. Most likely your IP is rate limited.

pamac build google-chrome
1 Like
  1. No proxy or vpn (I tried to install something from AUR from 3 pcs, and all of them are having same issue untill I switch them to another network).
  2. I typed your command and I got this:
Failed to query[]=google-chrome from AUR: error 429
Failed to query from AUR: error 429
Error: target not found: google-chrome

Then maybe your ISP spat out a bad dynamic IP. Whoever used it last abused the privilege, it seems.

The user has sent too many requests in a given amount of time (“rate limiting”).

If your system is not up to date and you use the version of Pamac flooding the AUR, then that’s why.

Wow, cool to be honest, I was installing softwares from 3 pcs at the same time and maybe that led to the 429 error.
And what can I do in this situation? will waiting for some period of time help?
if yes then how long do I have to wait?

Idk, I just installed manjaro 21.1.6 (Pahvo) kde from official site and as soon as it was installed, I started downloading all necessary software from AUR.

pamac --version ?

:point_down: that’s not what I asked for. good version then.

Pamac 10.2.2-5

As I mentioned before, when I change the network, the problem dissapears, maybe AUR banned me for some period of time xd

Impossible. You have a bad dynamic IP. Release and renew it. If you don’t know how to to that, search the web.

You’d have to be checking for updates once every 20 seconds to hit the rate limiting at 4320 requests, one request per check (which means you’d run out less than 2 hours before the end of the day).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.