Add/Remove Software doesn't load after recent update

I don’t get any errors or warnings, just nothing. Program doesn’t load.

For information just to point out my system is up to date:
[toby@toby-server ~]$ sudo pacman -Syu
[sudo] password for toby:
:: Synchronising package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
warning: gnome-wallpapers: local (20201023-1) is newer than community (20201020-1)
there is nothing to do

Do you guys have any suggestions as to what might be wrong?

If it were my system I would try:

pacman -Syyuu

The yy will force an update of the sync database.

The uu will allow for a downgrade. Although the man page says, "This option works best if the sync database is referehsed using -Sy. I’m not sure why.

Please see man pacman and man pacman-mirrors.

Before you do the above, check the state of the repositories you are using at: and/or pacman-mirrors --status

local is referring to what is installed. community is referring to the sync database.

Display info about the package in the sync database:
pacman -Si gnome-wallpapers

Display info about the installed local package :
pacman -Qi gnome-wallpapers

It would be interesting to know what is in cache too:
find /var/cache/pacman/pkg -iname '*gnome-wallpaper*'

Pay attention to the version in each of those 3 commands.

You can downgrade this single package with the command mentioned above.
This nothing to worry about.

Try using terminal command to run pamac GUI and check any error messages

pamac-manager %U

I ran “pacman -Syyuu” and that has resolved the gnome-wallpapers issue, thank you for that suggestion.

The original problem of clicking ‘Add/Remove Software’ still persists though. When I double click this in the UI, it creates the activity button on the top bar for a few seconds which then disappears and the program hasn’t started. No errors, nothing.

Running nikgnomic’s suggestion returns this:
[toby@toby-server ~]$ pamac-manager %U
pamac-manager: symbol lookup error: /usr/lib/ undefined symbol: pamac_transaction_get_loop

I have temporarily fixed it. I updated pamac again, then ran pamac-manager %U which gave me this error:
pamac-manager: symbol lookup error: /usr/lib/ undefined symbol: pamac_transaction_get_build_files
See this exiting issue:

Then I installed the pamac-gtk-dev (sudo pacman -Syu pamac-gtk-dev) which has resolved the issue.
I’ll need to revert to pamac-gtk at some point though.

I am facing the same issue, have you successfully reverted to pamac-gtk?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.