Add dualboot for existing Windows installation on other drive

Hey there,
This is more or less a follow up on the topic here where my original Manjaro System got screwed up somehow and i tried to fix it.
I don’t remember everything anymore, but in the end a complete reinstall of Manjaro on my new NVME-SSD with the Windows SSD detached did the trick.

The thing is, I still got my old 250GB SSD with Windows installed on it, which i would like to use to play some games that are not compatible with Linux (yet).
The installation still works, but to boot the Windows system, I always have to manually select the smaller SSD in the UEFI Menu.
I guess that’s because I now have 2 EFI partitions and 2 bootloaders that don’t know about each other system.

It looks like this:

~ >>> sudo parted --list                                                       
Modell: ATA SanDisk SDSSDHII (scsi)
Festplatte  /dev/sda:  240GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende   Größe   Dateisystem  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          versteckt, diag
 2      524MB   629MB  105MB   fat32        EFI system partition          msftdata
 3      629MB   646MB  16,8MB               Microsoft reserved partition  msftres
 4      646MB   240GB  239GB   ntfs         Basic data partition          msftdata

Modell: ATA ST1000DM003-1SB1 (scsi)
Festplatte  /dev/sdb:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt

Nummer  Anfang  Ende    Größe   Dateisystem  Name  Flags
 1      1049kB  1000GB  1000GB  ext4

Modell: WDS100T3X0C-00SJG0 (nvme)
Festplatte  /dev/nvme0n1:  1000GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende    Größe   Dateisystem     Name  Flags
 1      2097kB  317MB   315MB   fat32                 boot, esp
 2      317MB   982GB   982GB   ext4
 3      982GB   1000GB  18,3GB  linux-swap(v1)        swap

~ >>>   

What I would like to have is somehow unify the two EFI partitions and have one single Grub bootloader where i can conveniently select the OS which I would like to boot.
I already tried executing update-grub on the Manjaro system, but this command didn’t find the Windows installation.

Any advice would be helpful

Hello @MajorMayer :wink:

True thing. Easy would be using /dev/sda2 as unified efi partition and just install grub there.
Keep in mind that the UUID will change and therefore you will need to change it in etc/fstab :wink:

Soo just to make sure i will not instantly destroy my working system. I guess you are referring to this section here right:

root # grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
root # grub-mkconfig -o /boot/grub/grub.cfg

The thing is, currently the partition /dev/nvme0n1p1 is mounted to /boot/efi, because that’s the bootloader i’m currenty using for booting Manjaro.
So do i have to temporarily mount the /dev/sda2 partition to a random folder, or do I really need to execute all the steps from this guide in a Manjaro Live system?

Also i cannot find the often stated manjaro-chroot script that I apparently need to execute all of this (right?).
Is this a special program that i have to download before or is it only included in the Live systems?

And in the unlikely case that all of this succeeded, do i have to delete my old EFI partition on /dev/nvme0n1p1?

Sorry I’m a bit confused about all of this :face_with_raised_eyebrow:

Soo it took me a while, but after reading through this post on Reddit i decided to try the systemd-boot method.
So I mounted the EFI partition from the Windows disk and copied the files into the /boot/efi/EFI directory.
It didn’t work immediately though, I guess that’s mostly because Manjaro doesn’t use systemd-boot by default but GRUB instead, which is perfectly fine for me.

After that i decided to install the rEFInd boot-manager (not -loader, I know that there’s a difference between them now) and it was ugly but worked well.
Eventually I executed update-grub once again, because some UUIDs changed, as you expected, and well, out of nowhere my Windows boot-loader appeared.

Maybe it’s because of the files, that i copied to the Linux NVME EFI partition or because the install script of rEFInd found something… I don’t really know what did the trick.
GRUB as a boot-manager is more then sufficient for me and now that it has all the entries, i uninstalled rEFInd again and used efibootmgr to switch back to the Manjaro GRUB bootmanager.

Thank you anyway for pointing me in the right direction :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.