Adb not recognizing android phone. How to properly install android tools?

adb is installed and working in terminal but command adb devices returns no info.
USB debugging and root adb are running on the Samsung S5 in dev options.

Samsung phones do not always adhere to the standard adb.

They use another tool - odin - which with linux equivalent to heimdall (named after the guardian of the bridge to valhalla).

The android tools and udev rules (@robin0800) are installed with

sudo pacman -Syu android-tools android-udev

The udev package adds identifiers for known USB devices, and an adbusers and rules which simplifies access to devices if user is member of adbusers group.

To be able to use the android tools you probably need to add yourself to the adbusers group

sudo gpasswd -a $USER adbusers

Logoff and login for the change to take effect.

Install “android-udev” and then add yourself to the adbusers group

How to do this ?

With the terminal.

Even @linux-aarhus has command.

Do i replace $USER with my user name ?

Yes you do.

I was going respond with yep. but the froum software went no.

Just for future reference, there is no need to replace it. The $USER would work. It contains the username.
So basically the answer to the question should be no. Use the command as @linux-aarhus wrote. Also do not forget to log out or reboot.

[kdf-pc@kdf-hp ~]$ adb devices
List of devices attached

[kdf-pc@kdf-hp ~]$

still no devices

Android tools do not include android-udev needed for adbusers

Ive the adb users updated and accepted.
Still no connection

What’s the output of lsusb while your phone is connected?

You are right - thank you for the correction :+1: