Activate integrated Intel GPU of a MacBook Pro Mid 2014

my macbook pro model deactivates the integrated intel gpu on every system except osx. right now i’m using the nvidia graphics.

there is an efi program that activates the internal graphics.

in short I think there is an efi file chainloaded so that the laptop thinks it starts osx.

you have to copy the file to the efi folder and edit the 40_custom grub file.

although it is advertised in the arch wiki it won’t work on my system. I had it working on ubuntu before.

I think there is a problem with the 40_custom changes.

if I follow the official instructions from the link above I have to add the following to 40_custom

search --no-floppy --set=root --label EFI
chainloader (${root})/EFI/custom/apple_set_os.efi

after update-grub and reboot nothing changes. the integrated graphics card is not visible with lspci | grep VGA

there is another site, that explains the same efi program but with another 40_custom entry.

there the addition to 40_custom looks like

search --no-floppy --set=root --file /EFI/custom/apple_set_os.efi
chainloader /EFI/custom/apple_set_os.efi

If I use these changes and reboot. Manjaro hangs on boot and I had to chroot and cancel the changes.

Does anyone know how to chainload this file to make it work?

I wish I could post the links to the sites, but somehow I am not allowed.

Thank you for your help!

Did you copy the apple_set_os.efi binary to the efi partition first, as explained here? GitHub - 0xbb/apple_set_os.efi: Tiny EFI program for unlocking the Intel IGD on the Macbook Pro 11,3 for Linux and Windows

hello. thank you for your answer. yes I copied the file as described in the instructions.

Well, first can you give the output of
inxi -Fz
to check if yours is indeed a mbp 11,3 - ’ MacBook Pro Mid 2014’ isn’t enough info, there’s more than one model.

it is an mbp 11,3

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 Desktop: GNOME v: 42.4
    Distro: Manjaro Linux
  Type: Laptop System: Apple product: MacBookPro11,3 v: 1.0
    serial: <superuser required>
  Mobo: Apple model: Mac-2BD1B31983FE1663 v: MacBookPro11,3
    serial: <superuser required> UEFI: Apple v: 433. date: 03/16/2022
  ID-1: BAT0 charge: 97.0 Wh (100.0%) condition: 97.0/97.2 Wh (99.8%)
  Info: quad core model: Intel Core i7-4870HQ bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 1075 min/max: 800/3700 cores: 1: 1091 2: 1098 3: 1018
    4: 1098 5: 1006 6: 1098 7: 1098 8: 1097
  Device-1: NVIDIA GK107M [GeForce GT 750M Mac Edition] driver: nvidia
    v: 390.154
  Display: x11 server: v: with: Xwayland v: 22.1.3 driver:
    X: loaded: nvidia gpu: nvidia resolution: 2880x1800~60Hz
  OpenGL: renderer: GeForce GT 750M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.154
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 465.92 GiB used: 34.19 GiB (7.3%)
  ID-1: /dev/sda vendor: Apple model: SSD SM0512F size: 465.92 GiB
  ID-1: / size: 448.53 GiB used: 34.19 GiB (7.6%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 620 KiB (0.2%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 448.53 GiB used: 34.19 GiB (7.6%) fs: btrfs
    dev: /dev/sda2
  ID-4: /var/log size: 448.53 GiB used: 34.19 GiB (7.6%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: partition size: 17.09 GiB used: 0 KiB (0.0%)
    dev: /dev/sda3
  System Temperatures: cpu: 67.0 C mobo: N/A gpu: nvidia temp: 64 C
  Fan Speeds (RPM): N/A
  Processes: 292 Uptime: 1h 3m Memory: 15.54 GiB used: 3.06 GiB (19.7%)
  Shell: Zsh inxi: 3.3.20

Under ‘issues’ Search line in /etc/grub.d/40_custom is not generic · Issue #23 · 0xbb/apple_set_os.efi · GitHub

“Search line in /etc/grub.d/40_custom is not generic”

So first run:

# grep "set=root" `find /boot -name "grub.cfg"` | tail -1

then use output:
search --no-floppy --fs-uuid --set=root 00000000-0000-0000-0000-000000000000

to edit 40_custom:

search --no-floppy --fs-uuid --set=root 00000000-0000-0000-0000-000000000000
chainloader (${root})/EFI/custom/apple_set_os.efi

Update grub…

I get this output

search --fs-uuid --no-floppy --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  faa55db0-ec60-49ef-8ff4-57fdf794625a

I also read that comment in issues and added the shown number behind root.

so just use this?

search --no-floppy --fs-uuid --set=root faa55db0-ec60-49ef-8ff4-57fdf794625a
chainloader (${root})/EFI/custom/apple_set_os.efi

I think I already tried it. but I will try again.

I’d put the full output in.

I’ll use this then

search --fs-uuid --no-floppy --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  faa55db0-ec60-49ef-8ff4-57fdf794625a
chainloader (${root})/EFI/custom/apple_set_os.efi

lspci | grep VGA still only show the NVIDIA graphics.

Hmm. Short of checking the process again, I’m running out of ideas, sorry.

Checking the MacBookPro11,x - ArchWiki you’ll need the intel driver, a gpu switch and since 'gpu-switch will not completely power down the dedicated card, you will have to create a custom grub menuentry and compile a program that will power off the dedicated card."

Which sounds almost more hassle then it’s worth. I also wouldn’t be so sure that the integrated intel iris card (which will stress the cpu more) will be able to run


It already worked in Debian setup. It had some advantages on that system. battery life, heat etc.

I got it to work with this grub.d/40_custom

search --no-floppy --set=root --file /EFI/custom/apple_set_os.efi
chainloader (${root})/EFI/custom/apple_set_os.efi

Credits to

the combination of their grub.d/40_custom files worked.

ty for your help also.

Glad you found a solution.

Try auto-cpufreq, been following this thread: Aggressive powersaving? and for me it brought temps down significantly on 2 older laps, one a nvidia mbp.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.