Acpi_call on g14 kernel

Kernel: 5.9.13-arch1-1-g14

Problem: acpi_call-dkms added with dkms, modprobed, doesn’t actually load, things that depend on it fail.

I had this working before, and I think now the new kernel or new kernel modules broke acpi_call. I only know a little about how modules work, so this might be a Newbie Corner question. I need acpi_call for tlp. It worked fine before. Everything I’m reading online isn’t working.

systemctl status acpi_call
Unit acpi_call.service could not be found.

tlp commands say
Error: battery charge thresholds not available.

which I tracked down to acpi_call. When I did modprobe acpi_call, it wasn’t found. I installed acpi_call-dkms, did the dkms install command, did modprobe, everything seemed fine. Rebooted, and nothing has changed.

TLP Thinkpad battery threshold function works on my system with the linux59-acpi_call package (I’m on linux59 kernel).

I tried the linux59-acpi_call first. Many resources suggested to use dkms.

Hello? Anyone out there know anything about acpi_call not loading?!