ACPI Bios Error on every startup (Creative X-AE5)

Hi community,

I experience the following errors / debug messages on every startup:

ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP7._PRW], AE_ALREADY_EXISTS (20230331/dswload-326)
ACPI Error: AE_ALREADY_EXISTSS, During name lookup/catalog (20230331/psobject-220)

ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP2._PRW], AE_ALREADY_EXISTS (20230331/dswload-326)
ACPI Error: AE_ALREADY_EXISTSS, During name lookup/catalog (20230331/psobject-220)

ACPI BIOS Error (bug): Failure creating named object [\_GPE._L08], AE_ALREADY_EXISTS (20230331/dswload-326)
ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20230331/psobject-220)

This points to my soundcard, the Creative X-AE 5. I am curious if anyone knows (or if anyone wants to find out with me) what the problem could be. Any help or hint or remotely connected knowledge with this error (or similar ones) is much appreciated.

Have a nice December!

Probably not your Creative since I do not have one and I have had this since forever on my Manjaro install.

[    0.257397] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP7._PRW], AE_ALREADY_EXISTS (20230628/dswload2-326)
[    0.257408] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20230628/psobject-220)
[    0.279999] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.GPP2._PRW], AE_ALREADY_EXISTS (20230628/dswload2-326)
[    0.280006] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20230628/psobject-220)
[    0.280016] ACPI BIOS Error (bug): Failure creating named object [\_GPE._L08], AE_ALREADY_EXISTS (20230628/dswload2-326)
[    0.280022] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20230628/psobject-220)
$ inxi -Fazy

System:
  Kernel: 6.6.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.6-x86_64
    root=UUID=700d034d-b99a-482b-880b-9060acf3a6b3 rw rootflags=subvol=@
    nvidia_drm.modeset=1 resume=UUID=5ae8fbf5-a704-41ea-be6d-bf26b38325ed
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F11
    date: 11/08/2023
CPU:
  Info: model: AMD Ryzen 9 7900X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 1303 high: 4820 min/max: 400/5733 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 400 8: 3254 9: 4723 10: 400 11: 400 12: 400 13: 3593
    14: 400 15: 400 16: 400 17: 400 18: 400 19: 4820 20: 4093 21: 400 22: 400
    23: 3600 24: 400 bogomips: 225271
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
    v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2023-11; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none empty: DP-1,
    DP-2, DP-3, HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2204 class-ID: 0300
  Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-2 empty: DP-4,DP-5,DP-6
    bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 42.0 C
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: Asus VX279 serial: <filter>
    built: 2015 res: 1920x1080 hz: 60 dpi: 79 gamma: 1.2
    size: 621x341mm (24.45x13.43") diag: 690mm (27.2") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
    surfaceless: drv: nvidia x11: drv: radeonsi inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics
    (raphael_mendocino LLVM 16.0.6 DRM 3.54 6.6.3-1-MANJARO)
    device-ID: 1002:164e memory: 500 MiB unified: no
  API: Vulkan v: 1.3.269 layers: 9 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 3090 driver: nvidia v: 545.29.06
    device-ID: 10de:2204 surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.1.9-manjaro1.1 device-ID: 1002:164e surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 15:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.3-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0
    chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp15s0 state: down mac: <filter>
Bluetooth:
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:5 chip-ID: 0e8d:0616
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 4.09 TiB used: 1.68 TiB (41.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 23.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD30EFRX-68EUZN0 size: 2.73 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A80 scheme: GPT
Partition:
  ID-1: / raw-size: 122 GiB size: 122 GiB (100.00%) used: 59.88 GiB (49.1%)
    fs: btrfs dev: /dev/sda7 maj-min: 8:7
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5
  ID-3: /home raw-size: 104.53 GiB size: 104.53 GiB (100.00%)
    used: 53.54 GiB (51.2%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
  ID-4: /var/log raw-size: 122 GiB size: 122 GiB (100.00%)
    used: 59.88 GiB (49.1%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 38 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda6 maj-min: 8:6
Sensors:
  System Temperatures: cpu: 48.8 C mobo: 26.0 C gpu: amdgpu temp: 43.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 520 Uptime: 2m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.5 GiB used: 4.13 GiB (13.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1561 pm: pacman pkgs: 1552 libs: 432 tools: pamac,yay pm: flatpak
  pkgs: 9 Shell: Zsh v: 5.9 default: Bash v: 5.2.21 running-in: yakuake
  inxi: 3.3.31

When I asked about this on the forum I got the response, “just ignore it”, so that is what I have done.

1 Like

Hi bedna, I guessed so, these are debug messages, not critical errors after all. But still, I hate not knowing, what is going on. Debug messages appear for a reason, to De-Bug :slight_smile:
So, SB.PCI definetely points towards an PCI Soundcard. Do you have one installed?

I do not, other than the one on my mobo and my nvidia.

Check my inxi above, it shows my hardware so you can compare and see if we have something similar that causes this.

Same error message was posted in Arch forum recently

ACPI BIOS Error (bug) / Kernel & Hardware / Arch Linux Forums

Normal, generally a BIOS bug as mentioned, not really a concern if things work like they should.

Updating motherboard BIOS might stop error, If not:

[SOLVED] ACPI error - AE_ALREADY_EXIST - Linux Mint Forums

add the loglevel=3 kernel boot parameter to clear out these ACPI errors.

So hiding messages is a solution now? xD

But yes, doing this is most likely harmless if you are annoyed by the message. I want them there because just as nikognomic says, a mobo update might sooner or later fix these warnings and I want to know if/when it does.

Welcome to the “just ignore it” club.

1 Like

Realising that it is not a concern is the common ‘solution’ on many distributions

But if you would prefer a road less travelled there is this post from 2020:
How to Choose the Proper ACPI Kernel Argument

The optimal solution would probably be to contact motherboard vendor to get support for their proprietary firmware because it is not a Linux problem

1 Like

Only problem with that is I have a Gigabyte… Good luck to me with that. LMAO

Ah, welcome to the club :slight_smile:

It’s very interesting (and annoying) that the common idea here and in the ARCH forum is to just hide the error away, instead of finding out about the root of it. It’s supposed to be a BIOS bug. Ok. But why does it appear on multiple different Boards with different BIOSes (or does it?).
I know this is a probably a question that is on the level of a kernel maintainer, but nevertheless: It bothers me, not to know, why it pops up in the first place…

There is really nothing anybody can do about that kind of stuff.
The same with nvidia, so I hit the jackpot with both. xD

I did not have linux under concideration when the purchase was made or things would have been different for me.

The only sollution is to contact Gigabyte, and again, good luck getting them to respond.

My board became so fkn dangerously broken 2-3 weeks into the purchase, the fans polarity was inversed, so when I made temperature curves in bios, they were INVERTED!!! Ie, max speed when they should stand still and vice versa.

I reverted back to an earlier bios that I luckily had available.
Contacted them, zero response, the bios was still up… Weeks went by, the day after new bios release was out they responded with the recomendation to “ugrade my bios with new firmware”.
I fkn kid you not!

Gigabyte also has VERY close ties to Microsoft so… There’s that…

But blaming anybody in the open source community for “not doing enough” is pointless and unfair, there really are nothing to be done with closed source software. :frowning:

We just have to live with it.

But at least we most likely figured out why we have these warnings.

Edit
I just tried the windows kernel thing that was linked to earlier but it changed nothing for me btw.

Oh geez, I never meant it to be understood that way! I merely was trying to point out, that these problems are on a level of complexity, that only half-gods (such as kernel maintainers) may understand.

In all other points, I concur with you absolutely.

PS: Very entertaining story you had there with Gigabyte. The only thing left with these companies is sarcasm.

I have the same Soundcard, where do you experienced this errors?

journalctl -p 3 -xb won’t show them… maybe try 6.1 LTS?

They show up at system boot, so I guess they can be found in $ dmesg (noobish half-knowledge here) :slight_smile:

But as @bedna pointed out (and the links to the Arch forums show), this problem is not related to the Creative X-AE5. Instead it seems to be a motherboard manufacturer or even AMI Bios specific problem.

Gigabyte have released another BIOS update for your motherboard (F20a)
https://www.aorus.com/motherboards/X670-AORUS-ELITE-AX-rev-10-12/Support

20 BIOS updates in a year is more than I have seen for other Ryzen motherboards, but with different chipsets. If there are similar frequent updates from other main manufacturers (Asus, MSI, AsRock…) for this chipset it might be an AMD or American Megatrends LLC issue, but they are likely to be unresponsive

wimsbios.com/forum might have some useful information, but I have not been there for many years

For Linux BIOS experts I would suggest looking into Coreboot and Libreboot projects

@Kobold
The letters SB and AE in ACPI messages do not relate to Creative Labs Soundblaster Card

Could not resolve symbol [\_SB.PCI0.GPP2.BCM5] - Debian User Forums

ACPI BIOS Error : How can i resolve these errors? - Kernel, boot, graphics & hardware - EndeavourOS

especially when it is:

© 2022 GIGA-BYTE TECHNOLOGY CO., LTD. All rights reserved

Not my circus: Not my monkeys

Jesus! I never DID blame anybody in the community! What the heck… :slight_smile:

Yeeeeah, no, you saw my experience with the alfa released firmware above (when the fans polarity got reversed), I used to try every single alfa and beta out to see if it changes stuff, but all it does is create a huge workload (every single bios update breaks my manjaro install, I know how to fix it, but rather not over and over). Those updates are towards microsoft windows. My motherboard apparently has features supporting changing settings in windows. THAT is what those updates does (and tunes AMD 3d cpu stuff).
But the second a stable firmware is out, I install it. The F11 that I use came out 2 days before and that is what I will stick to until next stable release. Not risking my hardware again! Using alfa and beta firmware VOIDS MY WARRANTY!

I have played around with the chipsets a little. In my early install (read the first two weeks) I wanted to use fancontrol and that demanded stuff from the AUR, it was buggy and strange. I had to do stuff like adding kernel stuff described for OTHER Gigabyte motherboards (BM something IIRC, I found it in the wiki) to let linux find the fan interfaces. It did not feel great so I decided to stick to non hacks for the future, and here we are.

Yeah I hear you.
It is what it is, and I am where I am, I just have to “deal with it”, My choice of hardware are biting me in the ass from time to time, I just have to accept that. :frowning:

Thank you for the links though, I will look deeper into those.

I think he just quoted me, it’s not directed at you, I think… So blame me…
:innocent:

Nah, your to likeable :slight_smile:

1 Like

@Knecker
@nikgnomic
I also have a Gigabyte Board and Creative Soundblaster AE-5 but i dont see this errors in dmesg
but instead i see this error here:

acpi PNP0A08:00: _OSC: platform retains control of PCIe features (AE_ERROR)

Interesting. Though its seemingly unrelated to the Creative Card but instead a BIOS error.