ACPI BIOS Error could not resolve symbol

Hi everybody,

This is my first (technically second) post on this community. I’ve been using Manjaro KDE for almost a week on my Lenovo laptop and it all seems good for now, everything working properly from what I see.

But today after logging into KDE I noticed I was having some trouble connecting to my WiFi, so I rebooted and it connected alright. Just in case I checked the system logs and noticed this two messages spamming every second:

3/7/21 23:05 kernel ACPI BIOS Error (bug): Could not resolve symbol [^^^GFX0.AFN2], AE_NOT_FOUND (20200925/psargs-330)
3/7/21 23:05 kernel ACPI Error: Aborting method _SB.PCI0.LPCB.H_EC._QC9 due to previous error (AE_NOT_FOUND) (20200925/psparse-529)

I did some search and it seems a pretty common error, but I wanted to check if it can be something to worry about. One user from the IRC channel noted that the error was coming from this function:

Which is called here:

This seems to be related to power management, so I will clarify that after installing I was looking at some power management options (on Windows I used the conservation option from Lenovo Vantage frequently) like TLP, but dedided to not install anything for now (battery life is similar to Windows: 3-3.5h).

Apart from this the system works perfectly.
If someone can clarify something I would be grateful.

Edit: I will provide system info, I thought maybe it would be displayed somewhere from the one on the profile data.

Kernel: Linux 5.10.42-1
CPU: Intel Core i7-8550U

Also I just found this thread on the same error, so I will post it here. I tried searching before creating but couldn’t find it.

acpi-bios-errors-in-dmesg (sorry it doesn’t let me include the link)

I don’t know whether to mark the thread as closed or to delete it.