Accidentally deleted /usr/lib/ file "gvfsd-network"


  • I was trying to work out where the multicasts for things like AirPlay, airport, REDlink, printers, scanners etc were coming from.
  • Couldn’t see that avahi was running. Eg. ps -ef | grep avahi ??? Nope. Nothing.
  • Renamed gvfsd-dnssd and gvfsd-network in /usr/lib/ folder, and killed the processes pkill -9 {gvfsd-dnssd,gvfsd-network} , and restarted the NetworkManager.
  • concluded the multicasts did not come from those processes.


While renaming the files back to default, forgot to change the second parameter in the “sudo mv” command and so renamed gvfsd-dnssdRENAMED to gvfs-network.

  • Yes, the /usr/lib64/ folder is likewise affected, seems to just be a symlink.
  • Yes, the /lib/ folder too.


0.) I’ve yet to update and have the ISO on DVD. How to restore that file/package, whether from the ISO or some other means. I remain unable to use the internet from the machine.

1.) Will an online update (even be possible and) actually fix this?

The root filesystem is read-only for a reason. Now that you’ve learned your lesson and will never do that again… :stuck_out_tongue_winking_eye:

The package should already be in your cache. Remove your renamed folders and reinstall gvfs:

sudo pacman -U /var/cache/pacman/pkg/gvfs-1.48.1-3-x86_64.pkg.tar.zst

Indeed yes, ha, thank you and for the command. I always thought there was a cache but was searching for it and came across that folder with strangely only about a dozen hardware drivers in it (as pkg.tar.zst files, yes) and moved on.

Maybe this is related to pkgfile coming up as “degraded” in systemctl as specified in my last post.

True to this problem, I go to Pamac’s Add/Remove GUI program and type ‘gvfs’ in the search, and a bunch of packages (namely gvfs-afc, gvfs-gphoto2, (…)-mtp, (…)-nfs and (…)-smb) appear in the dropdown list. But when I click them there’s nothing, the interface/window is blank. Also when I open the Pamac History only those dozen drivers are shown with the three packages that I installed manually (tor, torsocks, tcpdump) as expected.

Note those three manually installed applications are not in the folder you specified (/var/cache/pacman/pkg/) either.


You can find the file in ISO. In ISO, there is a file manjaro/x86_64/desktopfs.sfs, mount the file. And just copy from MOUNTPOINT/usr/lib/gvfsd-network.

1 Like

This post appears to have two solutions but due to some strange anomaly with my packages list, it was the one immediately above that worked.

Thanks to you both!!!

Maybe that is because this is a new install? I tried installing Manjaro and there are only 17 files in cache.

1 Like

So maybe it is normal behavior. Interesting. I remember looking at the list on a fresh install in the past, and realized it showed the date I installed Manjaro on my computer. Maybe that only appeared after running a db update.

Will report back, for sake of curiosity. Thanks again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.