Accidentally deleted terminal and bottom panel

Hello! I’ve tried to solve independency conflict and accidentally deleted terminal (maybe, I’m not sure), and panel at the bottom of the screen (definitely sure). Also some shortcuts doesn’t work (prtsc or ctrl+alt+t), but, for example, ctrl+alt+f4 works.
As a result, I cannot open almost all (including terminal). I am lucky that there is a start manjaro info page at the beginning of the session, and I am capable to open browser and navigation between folders. But I cannot open anything else.
May, you, please, help me to restore all the deleted apps? Is it possible, or should I create a new Manjaro system from the USB?

You may be able to launch some things using krunner. I believe the default is

And in any case you should be able to get interaction at a TTY using
Ctrl+Alt+F# (F3, F4, etc)

You should also be able to reset your layout by something like

lookandfeeltool --resetLayout

You should be able to view recently removed packages by looking at the logs;

grep -i removed /var/log/pacman.log

If you believe you are missing core default packages and dont know how to go about finding and installing them all then you can use the mapare script;

To print any packages that are default but missing you could use

bash <(curl -s -IP

And enter your DE (kde) at the prompt.

To install those same packages just drop the P

bash <(curl -s -I

Of course also enter your DE (kde) at the prompt.


Welcome to the Forum! :slight_smile:

Does CTRL + ALT + T open Konsole for you? Or F12 for the Yakuake drop-down Terminal?

Also, you can (normally) add a new Panel via right-clicking on the desktop.

Alt + Space doesn’t work.
Ctrl + Alt + F3 sends me to the black screen and asks to write my login and password. I remember my password, but I forgot my login. Is it possible to find the login in some files?

Ctrl+Alt+T doesn’t work. The same for F12 and right-clicking.

Ok, username is ‘root’ ))

It would be better to log in as your user.

cat /etc/passwd | grep 100

… should show something. If it doesn’t, remove the | grep 100.

I did all you wrote, and I got this:

error: failed to commit transaction (conflicting files)
kglobalacceld: /usr/lib/systemd/user/plasma-kglobalaccel.service exists in filesystem
mkinitcpio: /usr/lib/initcpio/hooks/encrypt exists in filesystem

And then 5 same rows with error “exists in filesystem”
Should I delete all of these files or does the better way of eliminating these rows exist?

Thanks for the remark. Now I’m not under the root.

1 Like

I rebooted, now it looks better, but I still can’t install these deleted packages:
plasma-wayland-session (aka terminal)

pacman says me that it can’t find these packages.
May you, please, help me, how to install these packages?

I believe it’s Meta+Space nowadays, but you should normally also be able to invoke krunner by way of Alt+F2, or by simply starting to type the name of an application on an empty desktop.

It’s called a tty, also known as a character-mode virtual console. :wink:

Switch back to your GUI environment, open up konsole and enter the command whoami.

No, it’s not. Unless it is, in which case you are using the system wrongly. The root account should never be used for doing normal work, let alone with auto-login. Never!

Did I mention “never”?

Not only is this very dangerous for your own files, but it’s a surefire way to open up your system to compromise, which means that your system will also become a liability to everyone else on the internet.


Thanks for your previous messages! I installed those packages using

bash <(curl -s -I

Now I can use Alt+F2, prtsc, and even terminal. but there are still 3 problems:

  1. Bottom panel is absent
  2. All new opened apps appear at the upper-left part of the screen, and I can’t move them.
  3. ‘Win’ button doesn’t work.

How to solve these little remaining problems?

These are all issues of your user configuration I would guess.

Did you run lookandfeeltool --resetLayout ?
I would expect that to at least get you a panel back.

For general configurations you might need to remove things from .config and/or .cache and/or .local.

The basic steps are covered here:

But you could also try a fresh new user if only to test.

1 Like

Right-click the desktop and choose “Edit Mode”. You will be able to find existing panels — they can auto-hide, so your panel might still be there — or add new panels.

It is called the Meta key in Plasma, and if you mean hitting the key by itself in order to bring up the application launcher without combining it with another key, then that only works if you have an application launcher applet on your panel.

An alternative (for the time being) could be Alt+F1.


You did not actually say WHAT you did to ‘delete terminal’.

If you think it is your USER data, then if you start by renaming ~/.config to ~/.configFORKED - then log in again to see if it is fixed.

By default, Konsole should open with Ctrl-Alt-T, but on a default profile (mine is on Ctrl-Alt-T).

Check shortcuts - I launch krunner with Alt-Space.

1 Like

“User account”, please. Profiles are a Windows thing, going back to the single-user origins of that platform. That’s why browsers also have “profiles”. :stuck_out_tongue:

1 Like


Note that plasma-wayland-session has been repackaged and no longer exists in that form. It has been replaced by plasma-workspace.


baloo5 has been replaced by the Qt6 version; simply named baloo:


The same applies to kuserfeedback, however that might have been obvious with a little attention to spelling.



I really recommend to you to buy a external ssd/hdd and create timeshift snapshots on a EXT4 Partition with Rsync Enabled.

When ever you run into issue you can simply rely on Timeshift to restore your System easily and quick.

1 Like

I had tried

sudo pacman-mirrors --api --set unstable
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

before crashing and it lead to the problem in the topic.

Please provide the full command output of:

sudo pacman -Syu

Maybe someone can gain some insight from this.