Accidentally deleted a folder and now no apps open

Hi , I am a Manjaro Xfce user. I was removing useless icon themes and folder which I had previously installed. While in the process I accidentally deleted the one that was active. Now I am not able to even open any apps nor is my xfce panel appearing. Is there any way I can open the appearance app just so I could change the active icon theme.

You may need to do this with command line (terminal via CTRL-ALT-F2) :wink:

Provide Information:

For example. Do you use btrfs with snapshots and timeline ?, Do you have a backup ?

1 Like

You can launch an application with Alt+F2.


Opening graphical applications from TTY won’t work, unless you start X there first, but that defeats the purpose of switching to TTY…


I am really grateful to the community for the quick response but I tried running xfce4-appearance-settings through xfrun4 ( Alt+F2 ) but as always it just opens and closes as I launch it

Also here is a little bit info on my system

  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=23a1d7e2-9556-4229-87c2-bd250d9163a9 rw quiet apparmor=1
    security=apparmor resume=UUID=59295e2e-0fec-428d-9349-772241c9a051
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: plank wm: xfwm 4.16.1 vt: 7
    dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 15g-dr0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 84A7 v: 80.31 serial: <superuser required> UEFI: Insyde
    v: F.07 date: 11/21/2018
  ID-1: BAT1 charge: 27.4 Wh (100.0%) condition: 27.4/41.0 Wh (66.8%)
    volts: 12.8 min: 11.4 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: Full
  RAM: total: 7.56 GiB used: 3.56 GiB (47.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm
    lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep sgx smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard
    driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:174e class-ID: 0302
  Device-3: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD Camera
    type: USB driver: uvcvideo bus-ID: 1-5:4 chip-ID: 05c8:03c7 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-6:5 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 6060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 931.51 GiB used: 207.22 GiB (22.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: RSM7 scheme: GPT
  Optical-1: /dev/sr0 vendor: hp model: DVDRW DA8AESH rev: XH6M
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 121.07 GiB size: 118.61 GiB (97.97%)
    used: 26.36 GiB (22.2%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 23a1d7e2-9556-4229-87c2-bd250d9163a9
  ID-2: /boot/efi raw-size: 489 MiB size: 488 MiB (99.80%)
    used: 10.2 MiB (2.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2 label: NO_LABEL
    uuid: A3CE-DAD5
  ID-3: /home raw-size: 651.93 GiB size: 640.69 GiB (98.28%)
    used: 180.85 GiB (28.2%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 10179855-c42b-4b7a-8f62-122c3f3d57ad
  ID-4: /home/<filter>/Cloud/Mount/aka-drive raw-size: N/A size: 15 GiB
    used: 3.1 GiB (20.7%) fs: fuse.rclone remote: aka-drive:
  ID-5: /home/<filter>/Cloud/Mount/athe-drive raw-size: N/A size: 15 GiB
    used: 661.8 MiB (4.3%) fs: fuse.rclone remote: athe-drive:
  ID-6: /home/<filter>/Cloud/Mount/dropbox raw-size: N/A size: 2 GiB
    used: 47.2 MiB (2.3%) fs: fuse.rclone remote: dropbox:
  ID-7: /home/<filter>/Cloud/Mount/onedrive raw-size: N/A size: 5 GiB
    used: 25.8 MiB (0.5%) fs: fuse.rclone remote: onedrive:
  Kernel: swappiness: 30 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 5.59 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 59295e2e-0fec-428d-9349-772241c9a051
  ID-1: /dev/sda5 maj-min: 8:5 size: 37.25 GiB fs: ext4 label: N/A
    uuid: c4469971-145a-4032-a062-086ad0a5637a
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c534 class-ID: 0301
  Device-2: 1-4:3 info: Alcor Micro Multi Flash Reader type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA
    chip-ID: 058f:6366 class-ID: 0806 serial: <filter>
  Device-3: 1-5:4
    info: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD Camera
    type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 05c8:03c7 class-ID: 0e02 serial: <filter>
  Device-4: 1-6:5 info: Realtek Realtek Bluetooth 4.2 Adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 500mA chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 67.0 C pch: 65.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 288 Uptime: 1h 32m wakeups: 1 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1409
  pacman: 1379 lib: 367 flatpak: 20 snap: 10 Shell: Bash v: 5.1.12
  running-in: xfce4-terminal inxi: 3.3.11

Thank you all for replying

You can try re-installing all packages, it should restore folders/files which came from packages.


Then you must edit the configuration from TTY:

xfconf-query -c xsettings -p /Net/IconThemeName -s <icon_theme_name>

You can find the list of available icon themes with:

ls /usr/share/icons/
ls ~/.icons/
1 Like

Okay ,So thank you everyone for all your help, so what happened was when I deleted the icon pack it was fixed in that icon pack making all systems reliant on it not able to access any icons causing system wide errors when trying to access the icons. So when I restored it from trash for time being it worked but it again broke , So ultimately when i totally removed the ~/.icons the icons pack got reverted to classic adwaita which saved my ass from a system wide package re-installation :sweat_smile: .Anyways Thank you to everyone who helped !!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.