AC1300 / RTL88x2BU Wifi Dongle Driver Solution - Many thanks!

FIRST POST: I haven’t even introduced myself but may do that elsewhere. For now I just wanted to extend MANY THANKS to @Mirdarthos … who posted a solution back in Sept '21 to help get a WU1300/AC1300 wifi dongle working … simply:

pamac build rtl8822bu-dkms

After 2 solid days/nights of frustration - trying to get my brand new Manjaro install (ok, I’m a first timer) to recognize my Cudy wifi dongle (Realtek chipset rtl88x2bu) - his simple solution worked brilliantly for me in less than a minute…

I knew the dongle itself was functional and my hardware (an old Dell Optiplex 7010 resurrected from office surplus) could handshake with it because I had the dongle working perfectly on Ubuntu (21.10) for a couple of months. (Although as I recall that was also a bear to get up and running the first time, as a complete newbie).

The more I learned about Ubuntu (and its commercial practices) and the more I learned about the allure of Arch, the more I was drawn to give Manjaro a try. I almost gave up in tears.

Ultimately, @Mirdarthos 's suggestion was the thing - after trying every other lead I found from Cudy, Realtek, Youtube, various github attempts, etc., that just plain worked without any fuss.

THANK YOU! My goal in posting this is to encourage other(s) having similar problems to give this solution a try. At least in my n=1 situation, it was the perfect solution to much frustration.

1 Like