Abnormally slow connection/exchange speed on WiFi hotspot

Earlier (last time - couple months ago) it worked just fine.
Now, when I turn on wifi+hotspot connection and connecting a smartphone in the vicinity of my laptop, the speed of hospot is abnormally slow: it’s in range ~20-400 B/s. Can’t load/transfer anything.
What I’ve already tried with no avail: restart NetworkManager service, remove/create hotspot connection (also with wihotspot-gui tool, which was throwing errors), restart the machine.


$ inxi -b
  Host: roman-pc Kernel: 6.5.0-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.7 Distro: Manjaro Linux
  Type: Laptop System: Dell product: G3 3779 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 04R93M v: A00 serial: <superuser required> UEFI: Dell
    v: 1.2.1 date: 07/18/2018
  ID-1: BAT0 charge: 11.9 Wh (100.0%) condition: 11.9/56.0 Wh (21.3%)
  Info: 6-core Intel Core i7-8750H [MT MCP] speed (MHz): avg: 1733
    min/max: 800/4100
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 535.104.05
  Device-3: Realtek Integrated Webcam driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915,nvidia,nvidia-nvswitch
    resolution: 1: 1920x1080~60Hz 2: N/A
  API: OpenGL v: 4.6 Mesa 23.1.6-2 renderer: Mesa Intel UHD Graphics 630
    (CFL GT2)
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Local Storage: total: 2.05 TiB used: 446.8 GiB (21.3%)
  Processes: 328 Uptime: 2h 23m Memory: total: 16 GiB available: 15.48 GiB
  used: 5.48 GiB (35.4%) Shell: Bash inxi: 3.3.29

Underway, it could also emit the following message (though I successfully entered the password on hotspot connection in separate popup) without formal connection breakage:


i have not a good idea right now, we need more info. Pls. show us the output of

ip link show


ip route show

Maybe it has something todo with a wrong DNS config, try

( nmcli dev list || nmcli dev show ) 2>/dev/null | grep DNS

as explained in https://unix.stackexchange.com/questions/28941/what-dns-servers-am-i-using

And is IPv6 enabled (it should be, IMHO)?


$ ip link show 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 3c:2c:30:99:09:d6 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether b4:69:21:52:16:d8 brd ff:ff:ff:ff:ff:ff
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default 
    link/ether 02:42:05:8f:cc:97 brd ff:ff:ff:ff:ff:ff
$ ip route show 
default via dev eth0 proto dhcp src metric 100 dev wlan0 proto kernel scope link src metric 600 dev docker0 proto kernel scope link src linkdown dev eth0 proto kernel scope link src metric 100 
$ ( nmcli dev list || nmcli dev show ) 2>/dev/null | grep DNS

As for DNS: it’s set for ethernet connection and was recently recommended by my ISP (some day the eth connection was down and tech support gave me those dns addresses).

As for IPv6 for the hotspot connection - it worked without enabling that.
The current config tab for hotspot is:

Ok, what got my attention is that both Ethernet and Wlan are up and running, and default route is set to eth. The hotspot has a private non-routable IP address, i’m not sure how this hotspot works, maybe someone can jump in. So i believe the problem is that your hotspot doesn’t take over the default route and then everything (including DNS) tries to go out via eth which won’t work if this is not connected. I would have expected that the hotspot would offer DNS and a default route. Could this be some config on the smartphone side?


Earlier I just needed to connect smartphone to the SSID (hotspot) and that got it to the internet.
If I understood correctly, DNS gets into the way of forwarding wlan IP-connection over ethernet?
Should I manually add the current eth IP address and DNS addresses to IP config of the wlan connection on the smartphone?

no, i think that won’t help. But i’m not the hotspot expert, someone else? Try to disable eth and see if this helps. Why is eth up anyway? Is it also connected to the Internet as it has a public IP? If not, it should be off.


No, I got a direct, cabled ethernet connection - it’s main (no wi-fi router), hotspot is secondary (in “access point” mode, programmatically).

ah, now i got it. You want to connect the smartphone to your cabled ethernet via hotspot. I always looked the other way round, connecting the laptop to a hotspot of the smartphone.
How did you enable the hotspot then on the laptop side?


Simply, with 2 clicks (wifi + hotspot):