"a2dp-source profile connect failed: Protocol not available" after installing PipeWire

By following Arch wiki, i had recently replaced PulseAudio with PipeWire.
That sounds really great, but now i have a issue that i no way cannot connect my featurephone’s audios with Bluetooth anymore

Trying to connect with bluetoothctl i get:

[joseskvolpe@RaposoPC ~]$ bluetoothctl
Agent registered
[bluetooth]# connect xx:xx:xx:xx:xx:xx
Attempting to connect to xx:xx:xx:xx:xx:xx
Failed to connect: org.bluez.Error.Failed br-connection-create-socket

I get this daemon log by using systemctl status bluetooth:

bluetoothd[418]: src/service.c:btd_service_connect() a2dp-source profile connect failed for xx:xx:xx:xx:xx:xx: Protocol not available
bluetoothd[418]: profiles/input/device.c:ioctl_is_connected() Can’t get HIDP connection info
bluetoothd[418]: profiles/input/device.c:control_connect_cb() connect to xx:xx:xx:xx:xx:xx: Host is down (112)

[SOLVED] Bluetooth connect failed: br-connection-profile-unavailable. / Newbie Corner / Arch Linux Forums

Thank you
But that topic was about a issue in another pulseaudio-bluetooth package release. Since i’m on PipeWire now, i don’t use that package, pipewire-pulse replaces that package and should work with A2DP protocol, but it isn’t on my case.
So i cannot find a solution in that topic

I could now connect to FTP though after following instructions to re-pair my device, but it isn’t listing A2DP protocol wich i would like to make it work again

Checking installed bluez5 libraries in /usr/lib/spa-0.2/bluez5/, i have the following libraries:

libspa-bluez5.so            libspa-codec-bluez5-aptx.so        libspa-codec-bluez5-ldac.so
libspa-codec-bluez5-aac.so  libspa-codec-bluez5-faststream.so  libspa-codec-bluez5-sbc.so

Got it working :smile_cat::smile_cat::smile_cat:
I’m not sure what did made it to work exactly, but these are the stuff i made, in steps:

Reinstalled bluez
installed pipewire-enable-bluez5 from AUR, but then removed that since it didn’t worked
installed pipewire-zeroconf and manjaro-pipewire
removed pulse-autoconf (probably won’t make any changes for Bluetooth)
Reboot my system (restarting daemons didn’t worked)

:fox_face: Audio is really great, quality is really much better than PulseAudio, however it fails more often. They’re very old phones, by the way (a LG x350 and a Samsung GT-M2510) ;3

Edit: Microphone aren’t recognized anymore after that, i must made another mistake and i’m gonna take a look into that
Solution for microphone: Edit “/etc/pipewire/media-session.d/alsa-monitor.conf” and set api.alsa.use-ucm to true, then do systemctl restart --user pipewire pipewire-pulse

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.