A whole drive volume is missing in manjaro (it's not listed dolphin)

I installed two phisical drives in my desktop one SSD and one hdd. I divided my single hard drive into three volumes(partitions). On Windows, they all worked perfectly. One volume vanished after I installed Manjaro on my desktop. The other two volumes are operational. One of them had a ‘can’t mount’ problem that has now been resolved. Please assist me in restoring that ‘E’ local disc.

Hi @ssbin,

Linux != Windows, so there are no A:, B:, C:, D: drives.

Please see :point_down: for a better eexplanaation:

[Tutorial] Working with additional ‘drives’ - Contributions / Tutorials - Manjaro Linux Forum

Hope it helps!

1 Like

Can Windows see them all?

I suppose yes, because:

Or do you solely rely on Linux now?

I hope you took care not to install to this drive? :grimacing:

1 Like
lsblk                                                                                                                                                                                                                        ✔ 
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   300M  0 part /boot/efi
└─sda2   8:2    0 931.2G  0 part /
sdb      8:16   0 931.5G  0 disk 
├─sdb1   8:17   0  95.9G  0 part /run/media/rock/RockPort
├─sdb2   8:18   0   527M  0 part 
├─sdb3   8:19   0   484M  0 part 
├─sdb4   8:20   0   475M  0 part 
├─sdb5   8:21   0 385.7G  0 part /run/media/rock/Genernal
├─sdb6   8:22   0 226.6G  0 part 
├─sdb7   8:23   0 172.7G  0 part 
└─sdb8   8:24   0  48.8G  0 part 
sr0     11:0    1  1024M  0 rom

I can see all the drives in window.
I now solely rely on linux now.
I took care - Manjaro is installed in a separate SSD, not on my hard disc.

Please provide the output of:

sudo fdisk -l
1 Like
sudo fdisk -l       
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: CT1000MX500SSD1 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 364A7E44-726A-C04A-BE95-0E38AD47398B

Device      Start        End    Sectors   Size Type
/dev/sda1    4096     618495     614400   300M EFI System
/dev/sda2  618496 1953520064 1952901569 931.2G Linux filesystem

Disk /dev/sdb: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000DM003-1ER1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x524d96cf

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sdb1              63     718847     718785   351M 42 SFS
/dev/sdb2          718848  201745066  201026219  95.9G 42 SFS
/dev/sdb3       201745067 1953523119 1751778053 835.3G 42 SFS

Partition 1 does not start on physical sector boundary.
Partition 3 does not start on physical sector boundary.

Perhaps also provide
lsblk -f
as it shows more information similar to fdisk -l

Can you identify which is which from the output?
Which are present and which is missing?

I’m not familiar with “SFS” as a filesystem (from the fdisk -l output)

I found these when briefly looking:

Gentoo Forums :: View topic - Mounting SFS Filesystem [SOLVED]


Perhaps that can give you a clue what might have happened? I don’t know.

1 Like

There are only 2 drives connected to the computer.

If there are more in the computer, as you say, I suspect a faulty connection of whatever sort.

1 Like

Oh , yes I have only 2 phisical drives. A partition from one of the drive is missing… sorry…

Can you tell us
perhaps even based upon what output you already provided
and/or also based upon
lsblk -f
on which drive the missing partition is supposed to be?

Depending on what one looks at, there are 3 partitions
or 8 partitions
on /dev/sdb

Which drive is it missing from?

1 Like
lsblk -f                                                                                             ✔ 
├─sda1 vfat   FAT32 NO_LABEL 4D9D-E0D1                             299.1M     0% /boot/efi
└─sda2 ext4   1.0            141f02ba-ea52-45f9-b4e6-04dc783dbe3f  832.8G     4% /
├─sdb1 ntfs         RockPort F6AC2C03AC2BBD4D                                    
├─sdb5 ntfs         Genernal 46F23AC9F23ABD4D                                    

may be it is sdb3.
The missing volume had low storage allocated than sdb5. as far as I remember

Try this instead.

1 Like
LANG=C sudo parted -l                                                                                ✔ 
Model: ATA CT1000MX500SSD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      2097kB  317MB   315MB   fat32              boot, esp
 2      317MB   1000GB  1000GB  ext4         root

Model: ATA ST1000DM003-1ER1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      32.3kB  368MB   368MB  primary
 2      368MB   103GB   103GB  primary  ntfs
 3      103GB   1000GB  897GB  primary

Would those last messages explain why no file system is shown for two partitions? Would that be related to the present issue? :thinking:

I think so.

In windows I extended its size multiple times and it’s volume letter will be repeated many times in windows’s Disk Manager ( I think it broken into many pieces on the disk).

It’s looked like this but repeated more than that:

this screenshot is found on the internet

Could this be the cause?

It can be.

Another possibility would be the drive starting to fail, producing bad blocks at partition extremities.
S.M.A.R.T. - ArchWiki.

1 Like