A strange "GRUB>" prompt at boot

Hello there!

First of all, my apologies for this noob question.

Well, I am a little lost here. Just installed Manjaro (21.3.7-220816 - KDE edition) here, coming from Kubuntu. I am starting to setting things up, but a little thing is annoying me.

When the machine starts, a dark screen is displayed, with a “GRUB>” prompt. I have to enter “EXIT” there and press ENTER, so I can finally enter Manjaro.

But, any idea about what is happening here, please? Why that prompt prevents the OS initialization?

Thanks in advance for your help, and sorry once again for the trouble.


Please find below the ouput of inxi:

CPU: quad core Intel Core i7-7700HQ (-MT MCP-)
speed/min/max: 3435/800/3800 MHz Kernel: 5.15.60-1-MANJARO x86_64 Up: 12m
Mem: 2564.6/15882.6 MiB (16.1%) Storage: 2.27 TiB (21.9% used) Procs: 259
Shell: Zsh inxi: 3.3.20```

¿Hace you tried this in a terminal after booting?

sudo update-grub

If It doesn’t work, rename the /etc/grub.d folder and reinstall grub:

sudo mv /etc/grub.d /etc/grub.d.backup

sudo pacman -S grub

Thank you very much. The update does not worked. :frowning:

I’ll try now the other procedure.

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You can also use Maxi

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment
1 Like


Many thanks and sorry for the confusion. Just updated my post including the inxi output. :slight_smile:

So, I’ve done all the procedures. I also ended running sudo update-grub before reboot. But nothing changed that strange prompt at boot, unfortunately.

looks like uefi/bios issue, boot into uefi and check/modify boot order

Many thanks.

I’ll try right now.

Hi again,

So, @brahma , sorry for asking again. I thought I would be able to do that, but I can´t. :frowning:

But I accessed my BIOS and there I could see the following entries:

  1. blank
  2. Windows boot manager (ST2000LM007-1R8174)
  3. Windows boot manager

But, all the above seems a bit strange, doesn’t it?

you are dual booting with windows?
and the blank option is probably manjaro…
post output from:
test -d /sys/firmware/efi && echo efi || echo bios
lsblk -f


So, I had Windows, but removed it back in June. Even its partition was deleted.

Please find below the output:

│    vfat   FAT32 ESP       ACAC-1729                              38,6M    60% /boot/efi
│    ext4   1.0             48a23c44-4ccb-44d2-9319-62b3469c0221  452,8G     3% /run/timeshift/2596/backup
│                                                                               /
│    ntfs                   E4085F4E085F1F3C                                    
│    ext4   1.0             7300d384-1f79-4d4d-8a01-563ac70b9105  917,1G    21% /home
│    swap   1               911998ea-edbe-48cb-b0ac-cea32036ec53                [SWAP]
     ext4   1.0   Backups-Timeshif
                            05b5343c-f552-45ae-958c-71485f8fbb70   65,2G     0% /run/media/ewsg/Backups-Timeshif
     ntfs         SSD_Externo_Sandisk

Take a look at this…

Great! Thank you! I’ll take a look.

Hi again,

Thank you so much, and I tried to follow the procedures in the suggested article.

But, here the things are a bit different. For example, at the article the ouput of ls (hd0,1) displays a series of files and paths, as well as the root filesystem.

Here I was not able to see something similar. Here is the output of my ls:

(proc) (hd0) (hd0,gpt1) (hd1) (hd1,gpt8) (hd1,gpt7) (hd1,gpt6) (hd1,gpt5) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1)

For the above, I was able to find ext4 partitions only for (hd0,gpt1), which is an external SSD. (hd1,gpt8), which is the backup partition I’ve set for Timeshift.

From now on, there are only 2 partitions with ext4, gpt6 and gpt3.

But, I’m a bit lost here. I am not able to detect what is the correct one, as well as I don’t know why the same results were achieved (regarding the suggested article).

Sorry for bothering you. But I would love to count with your help one more time, if possible. :slight_smile:

Try this to see what’s in each partition (don’t forget the backslash at the end) and find the /boot folder:

ls (proc)\

ls (hd0)\

ls (hd0,gpt1)\

ls (hd1)\

ls (hd1,gpt1)\

And so on, until (hd1,gpt8). If /boot folder appears in (hd1), then try:

ls (hd1)\boot

To see what’s in the folder and the files you have to load before the “boot” command. Copy here the results and we’ll see what else can be done.

Hi @Arrababiski ,

Thanks once again.

So, I ran the procedures, but don’t know if I did something wrong. Well, because I obtained similar results.

Take a look at the below screenshot, please:

And again sorry for the disturbance and my dumb questions. :slight_smile:

It seems to me you have an EFI system and I know little about this configuration. Here you have more info to continue looking for information, tells us what you discover and let’s hope somebody else can help to find a solution:

No need to apologize, I’m glad to help in any way I can.

@Arrababiski ,

Thank you very much. Yeah, I have EFI here. I’ll read the suggested article and look for more informations, trying to solve this little issue.

This amazing community is really great!

Since I left Kubuntu I can only thank all the Manjaro community and team. Not only we have a great distro, we also have a wonderful support, with very kind and helpful people, like you. :slight_smile:

Moreover, I am really very well impressed by how Manjaro fantastically detected all my hardware with minimum efforts from my part. Even the Nvidia drivers (which caused several problems on Kubuntu including a broken system) were perfectly and automatically installed, and I am already running some games, including severam with Valve’s Proton.

1 Like

you still have this windows partition:

i would try reinstalling grub, boot into manjaro live usb, open terminal and chroot with:
manjaro-chroot -a
reinstall it:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

update it:
mkinitcpio -P && update-grub
if there are no errors exit chroot:
reboot and see if it helped

1 Like

Hi @brahma ,

Thank you very much.

Sorry for asking this (I am a bit afraid now since the entire system is working and there’s only that “little annoyance” when everything is booting).

Doing the above procedure is there some risk the system becomes unbootable or something similar?

P.S.: I also noticedt there’s a /boot/efi partition (sda1). May this be the correct one?

no nothing will break… but before you do that post also output from:
efibootmgr -v

1 Like