A running application asks for password when suspending to RAM the first time

Whenever I try to suspend my laptop to RAM the first time after booting, the system asks me to type in the root password, then it all works perfectly fine, I can suspend my computer and it doesn’t ask me the password again.

It never asked me before though, I don’t know what may cause this, I only remember changing the behaviour when closing the screen, which suspends the system.

██████████████████  ████████   alessandro@alessandro-pc 
██████████████████  ████████   ------------------------ 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: EasyNote TE11HC V2.04 
████████            ████████   Kernel: 5.10.84-1-MANJARO 
████████  ████████  ████████   Uptime: 10 mins 
████████  ████████  ████████   Packages: 1486 (pacman), 7 (snap) 
████████  ████████  ████████   Shell: bash 5.1.12 
████████  ████████  ████████   Resolution: 1366x768 
████████  ████████  ████████   DE: Xfce 4.16 
████████  ████████  ████████   WM: Xfwm4 
████████  ████████  ████████   WM Theme: Matcha-dark-azul 
████████  ████████  ████████   Theme: Matcha-dark-azul [GTK2] 
████████  ████████  ████████   Icons: Tela-blue [GTK2] 
                               Terminal: xfce4-terminal 
                               Terminal Font: Inconsolata 14 
                               CPU: Intel Celeron B830 (2) @ 1.800GHz 
                               GPU: Intel 2nd Generation Core Processor Family 
                               Memory: 1331MiB / 3746MiB 


No, it doesn’t break my pc but it’s pretty annoying, and I’m too noob to change system settings myself and I don’t want to break it.

If someone is willing to help me, thanks in advance.

try unticking the lock screen options in power manager and session and startup applications :point_down:


Please do not post screenshots of text.
Copy + Paste and use appropriate formatting via </> button or adding three backticks ` above and below the text.

A running application tries to explictly inhibt suspending (spotify or any media player running?) that’s why you’re asked for authentication to override this.

1 Like

These options were already unchecked, thanks!

I pasted and formatted the text, thanks.

It appears Audacious was running in the background, I must have opened and never closed it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.