A problem with default-url-scheme-handler (doesn't open a specific link with a browser i have dedicated i to)

When I, go to X(link) it should open a new tab with the link the X link opened on it should it not?
When i looked for similar problems all problems seemed to be fixed by setting these two variables in the mimeapps.list file:
It still doesnt work for me and just opens a new tab and not the tab with the link i clicked on

Note that,
xdg-settings get default-url-scheme-handler https
gives back;
xdg-settings: default-url-scheme-handler not implemented for xfce

For Firefox I would do

xdg-settings set default-web-browser firefox.desktop
xdg-mime default firefox.desktop x-scheme-handler/https x-scheme-handler/http

So adapt for Brave and tell if it works.

nope, unfortunately doesnt work!

neither does this, it opens a new tab but not with a page that is linked to the link

You’ll have to explain clearly what you mean, to me it doesn’t mean anything, make sure your explanation of the situation is clear because to me it isn’t at all.

if it is a http(s) resource - it will open in the defined browser - however if you are creating some kind on of non-default - then you need to create as schema handler - much like the package schema handler by pamac

I don’t recall the exact naming of the setting or the app controlling it but xfce has something called default applications

The easiest method would be to open the settings panel and locate Default Applications and set the browser from there.


Turns out, that in xfce4-mime-settings the default web browser was /usr/bin/Brave instead of /usr/bin/brave thanks, and apologies.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.