A lot of freezes with AMD Ryzen 5 3600

I have the exact same CPU and motherboard and there is absolutely no issue with Manjaro and this hardware, I play a lot of WINE games on Steam, watch a lot of HD medias, and spend too much time on my browser, I virtually never crash (and the computer can stay up to a week sometimes before I reboot it).

I had an issue though when I bought this hardware, I had inconsistent crashes and system failures. unexplainable.

Long story short, this issue was with the RAM. The default values in the XMP profile were theoretically correct, but I had to increase just a little the tRC value in the Bios to have perfect stability. This issue was replicable with multiple Corsair 3200 memory kits (I had multiple same RAM, CPU and motherboard in hands in the past year), today I have a Crucial 3200 memory kit and the default values in the XMP profile are all the same than the Corsair one, BUT the tRC is a little higher which made this memory kit work out of the box compared to the Corsair one. I would recommend to simply check what memory you have what are the values currently applied to it, and maybe just by configuring one value you could get out of trouble soon.

Don’t get you hopes up, but this could simply be it. To quickly confirm an issue with the RAM, just do a ‘Large FFT’ test with Mprime (for 10 minutes to up to how much time you have to waste waiting to see if errors come, it was relatively quick in my various cases) and it should spit errors if it detects RAM related issues, then from there you know issue may simply be what I’m talking about, and reconfiguring properly your RAM timings would fix it (Load XMP profile, then modify the tRC by increasing its value a little).

PS: and by the way, I use the default Bios settings only with the Power supply idle control on TYPICAL, and XMP profile loaded [and modified if default values are too tight], no messing around with other setting to have it stable (and now I even have the memory overclocked and other advanced settings but I used the computer without any ‘tips’ from the internet for the early Ryzen issues you can find from google)


Thanks, I have installed it and am using it. Let’s see if it works, if not I will try to change DE. Meanwhile I noticed that the wi-fi card problems were related to the 5.7 kernel, it apparently works well with the 5.4 LTS kernel, but now I have some weird graphical glitches. I’m starting to think the problem really is my graphics card.
Thanks so much for your help, I will update this thread if I find a solution. :slightly_smiling_face:

Thanks so much for your advice! Last night I reinstalled everything, this morning I changed the tRC values slightly (I’m not sure how much they need to be increased), but I also switched from the 5.7 kernel (now default in the new iso) to the 5.4 LTS because the 5.7 gave me a lot of problems with the wifi connection and I start to think that it could be the cause of everything. Anyway now the system seems pretty stable. No freeze today. If everything goes well for a few days I will mark the problem as solved :grinning:

From memory with the XMP profile values, I have set the 3200 Corsair kit’s tRC from 64 to 72 in the friends’ computers, if I’m not mistaken, and this should be the default on my Crucial kit.

If you have done multiple things now to fix the issues, you can’t be sure what fixed it, but if you notice no issue, when using normally, or checking with mprime (what I would have done first actually), then it’s great.

Yes, you are right, now I want to try to reset the tRC values to default to understand if the problem was the kernel or the ram. Thanks again. I update this thread as soon as I have a clear result.

I have the same issue with my Thinkpad E595 running a Ryzen 5 3500U. I have tried all the latest kernels : 5.4 and up. I even tried installing Linux Mint, thinking the kernel version they are using would have that problem solved. It seemed to work without issues from a live USB for hours, so I thought it worked, but turns out it has the exact same behavior now, after I have done all of the updates. I have no issues on my Thinkpad T420 (i7-2720QM), which is also running Manjaro.

Ok, after 2 days I can confirm 100% that my problem was simply the kernel.

Here’s what I did: 2 days ago I reinstalled the latest Manjaro ISO with Gnome, keeping all the default bios settings except “Power supply idle” set to “typical”. So, no ram settings change and C-state active.
With the kernel 5,7 (default in this iso) I immediately had problems with the wifi card (connection that comes and goes continuously) and several freezes. I therefore installed the 5.4 LTS kernel, choosing from grub to use that. And there you have it, no freeze in 2 days and perfectly stable wifi connection. I tried again to revert to kernel 5.7 and the system freeze in 3 minutes.
So now there are no more doubts, in my case the only problem was the 5.7 kernel, perhaps due to some incompatibility with my wifi card or with this processor in particular. Anyway, my problem is solved for now.
Thanks a lot to anyone who responded and helped me to solve the problem.
:grinning: :+1:

1 Like

I use Kernel 5.7 since release so yeah I confirm it is not an issue with the Mobo or CPU with this kernel, it is surely linked to your peripherals. What if you run Kernel 5.7 without the Wifi card plugged in (to cross check things)? If you have no issue on 5.7 when the Wifi card is not in the computer then this may be an issue worth mentioning upstream for it to be fixed, imagine if at 5.4 End Of Life the issue still exists in other kernels.

Do as you wish but if it is not too difficult or too time consuming for you, I advise you to try this way you would finish the troubleshooting and could even report a bug :stuck_out_tongue:

OMG, you hate me :sweat_smile:
Ok, I’ll try in the next few days. The only problem is I have the pc a bit far from the router so I have to try it without internet. But I’ll make one last try. If so, where should I report this kernel bug?

I’m not even sure myself but maybe at least in the relevant (last?) update thread here, or directly at the Kernel.org webpage Reporting bugs — The Linux Kernel documentation by giving all your hardware info.

1 Like

OK perfect. Let’s see what happens!

Good news. I have been tinkering with different configurations and I think I’ve narrowed down a possible cause for the freezes to my USB-C hub (ZMUIPNG 7 in 1) which has an HDMI output. It would not boot to the desktop at all with that plugged in, using a live USB key with Manjaro. I unplugged every devices from my laptop (Thinkpad E595) and everything worked flawlessly with the kernel 5.6.15-1. I have reinstalled Manjaro and no freezes so far. I’m scared of upgrading the kernel because of how stable it is right now. I’ll let you guys know in a few days how it went.

It froze about 30 minutes after I’ve plugged in an external monitor from the built-in HDMI port. I need to do some more testing.

It seems to be a bad RAM module. Even though I ran many tests and returned no problems. Seems to be stable with one of them. The other one does cause me issues.

Glad you found the problem. What program did you use to test the ram?

I ran Memtest86+ for at least 30 minutes without any issues. Memtest86 would just lead to a black screen when I actually started the test. I could go back, but I just couldn’t see anything. Apparently, it’s a common issue with UEFI. I actually think there is something wrong with my AC adapter now, or something with the voltage regulation inside the laptop. I’ve noticed it works fine on battery and even while charging. I get issues when it gets past 97% charge. It’s so weird.

Thanks, I’ll do some tests too :slightly_smiling_face:

Do you think it could be caused by an M.2 NVME drive? I don’t recall having that many issues until I switched to a different drive. I believe it did freeze a few times in the past, but never under Windows. Now, it does happen under Windows as well.

I have removed the heatsink on the M.2 drive and just reinstalled it and left the bottom cover off. Seems stable so far. I don’t see how that could affect the stability of the system only while it’s fully charged and plugged in, but we’ll see. :slight_smile:

It seems that it could be a problem with my M.2 drive. I found this post on reddit from a user who seems to have the same problem with his Western Digital SN550. I hope this is helpful for the people that are experiencing this and I’ll definitely try some of their suggestions or just pop back my old M.2 drive if it doesn’t solve my problem. The original post : https://www.reddit.com/r/pop_os/comments/g8y3ae/experiencing_random_freezes_after_installing_new/

A quote from the user in question :
"I’m a fedora user and I just installed the 500GB version of the WD SN550 in my Motile M141 (Ryzen 3 - 3200U) laptop. I’ve been seeing the same thing as you initially described, but I don’t have a USB-C dock to remove! :slight_smile: I’ve tried going back to Fedora 31 (initially installed F32 beta), but it still happened there. Currently running from the Live USB to see if the freeze happens again or not. It’s definitely driving me nuts, and like you pointed out, there doesn’t seem to be any useful info in logs.

I did stumble across these links which mention disabling some power saving functionality with a kernel boot parameter. I have not tried them out yet, so try them at your own risk"