A graphics card or driver with support for opengl 3.3 or higher is required

Blender stops immediately when I try to launch it.  When I launch it from the terminal it outputs this:

[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.

I have a ryzen 3 3200g with integrated vega 8 graphics.

Please post the output of inxi -Fazy.

It won’t let me post the entire thing because it says there are links inside, but I can try to post a specific part or look for information. And sorry this took so long.

Then try inxi -Gazy.

Here. Where it says (dot) there used to be a period, but it counted as a link so I took it out.

Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel
bus ID: 08:00.0 chip ID: 1002:15d8
Display: x11 server: X(dot)Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.5x13.2") diag: 686mm (27")
OpenGL: renderer: N/A v: N/A direct render: N/A

What’s the output of glinfo | grep VERSION?

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 24 (X_GLXCreateNewContext)
Value in failed request: 0x0
Serial number of failed request: 31
Current serial number in output stream: 32

Are the mesa and libglvnd and xf86-video-amdgpu packages installed?

According to Pamac, yes.

Can you post the latest Xorg log? (it’s either in /var/log/ or ~/.local/share/xorg/)

The latest Xorg log is 830 pages long for me. Maybe I could just post the beginning?

Then run cat <filename> | curl -F 'clbin=<-' https://clbin.com, and then post the link you get (modify it so that the forum accepts it).

I cannot see anything out of order there. I don’t think it’d change much but have you tried rebooting?

Yeah, it didn’t do anything. I’ll try messing with the drivers.

I’m not sure if you ever found a solution for this, I was getting the same error. I installed both the arch version and downloaded the portable version from blender’s site, trying to start either one gave the same error, I uninstalled the arch version and all the orphan packages, then tried the portable version again and it loaded like normal. I also noticed screen tearing occur after I had blender installed which also went away after I uninstalled it.