8GB RAM limited to 2.8 GB on Lenovo Tablet

hey there,

I have manjaro gnome running on a Lenovo Ideapad 700 and it’s great so far, but I have only 2.8 GB of my 8 GB RAM available. Any ideas? Don’t know where to start

Cheers, Phil

Welcome at the forum, @philx,

can you please provide some info about your system by entering

inxi -Fxxxza --no-host

in a terminal window. A possible reason could be that you use a graphic card with shared memory, i.e. a part of your RAM could be assigned to your graphic card. Certainly it could also be that one memory bank is not detected.

Thanks for fast reply… i thought about the shared memory too, but it would be rather unusual to have 5.2 gb memory for intel graphics. I tried the manjaro live usb image, the limit is there from beginning. In W 10 I get the full 8 GB. inxi output:

  Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=6fa50031-86d9-465a-bf8e-b9dcb51e6376 rw quiet apparmor=1 
  security=apparmor resume=UUID=6e7f61f8-abaa-4e7c-85c7-e224cb45ddac 
  Desktop: Gnome 3.36.4 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 80QL v: MIIX700-12ISK 
  serial: <filter> Chassis: type: 10 v: MIIX700-12ISK serial: <filter> 
  Mobo: LENOVO model: VIUU4 v: SDK0K17763WIN serial: <filter> UEFI: LENOVO 
  v: DFCN52WW date: 12/13/2016 
  ID-1: BAT0 charge: 22.4 Wh condition: 30.7/40.6 Wh (76%) volts: 7.9/7.6 
  model: LGC L15L4P71 type: Li-poly serial: <filter> status: Discharging 
  Topology: Dual Core model: Intel Core m5-6Y54 bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: D6 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 12007 
  Speed: 1300 MHz min/max: 400/2700 MHz Core speeds (MHz): 1: 1300 2: 1300 
  3: 1300 4: 1300 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 515 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:191e 
  Display: x11 server: X.org 1.20.8 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel HD Graphics 515 (SKL GT2) v: 4.6 Mesa 20.1.3 
  direct render: Yes 
  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging 
  vendor: Lenovo driver: ipu3-imgu bus ID: 00:05.0 chip ID: 8086:1919 
  Device-2: Intel vendor: Lenovo driver: ipu3-cio2 bus ID: 00:14.3 
  chip ID: 8086:9d32 
  Device-3: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70 
  Sound Server: ALSA v: k5.4.52-1-MANJARO 
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 01:00.0 chip ID: 8086:24f3 
  IF: wlp1s0 state: up mac: <filter> 
  IF-ID-1: wwp0s20f0u9c3 state: down mac: <filter> 
  Local Storage: total: 246.09 GiB used: 26.62 GiB (10.8%) 
  ID-1: /dev/sda vendor: Samsung model: MZNLN256HCHP-000L2 size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 3L0Q scheme: GPT 
  ID-2: /dev/sdb type: USB model: SMI USB size: 7.62 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: 1100 scheme: MBR 
  ID-1: / raw size: 62.76 GiB size: 61.52 GiB (98.03%) 
  used: 25.49 GiB (41.4%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 8.02 GiB used: 1.10 GiB (13.7%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda6 
  System Temperatures: cpu: 44.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 227 Uptime: 23m Memory: 2.77 GiB used: 2.16 GiB (78.0%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 
  running in: gnome-terminal inxi: 3.0.37

As I thought - in absence of its own graphics memory or eDRAM cache, your HD Graphics 515 accesses the system RAM via the processor’s interface and therefore you get the reduced available RAM indicated.

5 GB of GPU assigned RAM seems like a lot though.

My Lenovo IdeaPad comes with 8 GB aswell, but I have 6 GB available, because 2 of them goes to the GPU.

Not able to decode that information out of above output… Well, how to assign less mem to gfx? I doubt I need more than 0.5 GB…

ok it is not the shared memory… lspci says 256m are used

lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 515 (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 3812
	Flags: bus master, fast devsel, latency 0, IRQ 131
	Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 3000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

ok fellas solved this one myself. Bet no use in getting more details on my machine. 8GB installed. lenovo f**ked this one up.

for anyone having a problem with available RAM when they boot a usb drive on lenovo notebook or tablet check this out.

forums linuxmint com/viewtopic.php?t=266435
(forum says I’m not allowed to post links)

When you boot via BIOS manual boot selection called “novo key” on some machines - on my miix 700 it is press vol up + pwr - you get only a fraction of installed ram for any os. use this method to boot to w10 - same BS. Set BIOS to boot directly to any os, np u get full ram.

In all decades of dealing with computers I hardly ran into anything as absurd as this one. made my day.

can someone please replace “m5-6y54 tablet” with “lenovo” in head?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.