6.3.0rc3-1 kernel boot message: no such crypto disk found

Upgraded kernel. Now when booting, after typing full-disk encryption LUKS password, and LUKS drive unlock, I get TTY message on clear black screen which says: “error no such cryptodisk found. \n\n Press any key to continue…” (\n is newline)

After pressing Enter, system continues to boot and work normally.

Does anyone know what is this and why? Problem is isolated to only specifically happened because of this kernel update.

The kernel is marked rc (release candidate) because it is still in the process of being tested for bugs before release. This is probably one such bug, you should report it if it hasn’t been already.

Well if you can still boot into the older series, it might be a regression. If that is also not possible you may have a local issue: [SOLVED] error: no such cryptodisk found / Newbie Corner / Arch Linux Forums

1 Like

Running sudo grub-install once fixed this warning.

Maybe manjaro-KDE-kernel-settings-plugin should be aware when installing new kernel, that it needs to run this command as post-hook in the future.


It doesn’t.
grub-install might be needed after an update of the grub package (else the actually installed/used boot loader code is as old as your installation).


grub-install worked for me, thanks.

So what is actually updated when grub is updated? If not the bootloader code? The framework that can perfrom the grub install?

If so, then the very least grub should do is announce any breaking changes that necessitate a grub install.

I had the same problem with the stable upgrade to 6.1.21 yesterday. Fortunately the same fix seems to work.

1 Like

A few days ago I had the same problem, but it is not caused by the rc version of the kernel, the problem is that a grub update was released a few days ago and it messed up the boot system. I had to re-install grub as I could as grub-install didn’t fix the problem for me.

Everything contained in the package:

$ pacman -Ql grub

Without any further (manual) intervention this will only effect everything used when you (or your system on kernel updates for example) update grub configuration:

$ update-grub

Methinks upstream (aka grub developers) assumes installed bootloader code to be “in sync” with config generating code.

No. Your installed bootloader code simply was too old now for the new package version you installed.

1 Like

I have the same issue, but sudo install-grub wants me to specify a device. Do I just specify my boot sdd(/dev/sda), or do I specify a partition on there? If partition, then which from the following? My ssd is partitioned as such:

  1. sda1 unformatted 8MiB, bios-grub flag
  2. sda2 ext4 /boot
  3. sda3 ext4 /
  4. sda4 ext4 /home

You have to indicate the drive, not the partition. Keep in mind that grub is a boot manager that allows you to load the different operating systems that you may have on your hard drive partitions, therefore you should not indicate a specific partition, but the drive of your hard drive, so you must indicate install it to /dev/sda, if that is your drive.

1 Like

Thank you, now everything works as expected.

I have a plain Manjaro install, installed about a year ago , all setting in installer at default, just with FDE.

Since about a week ago , I also got the same message
“error no such cryptodisk found. \n\n Press any key to continue…” (\n is newline)
Luckiliy everything worked after pressing a key.

Thereafter, I upgraded from kernel 5.15 to 6.1 , but that did not change a thing (for the better or worse).

Good that I found this thread, however even before I was concerned with every reboot, what do I do if something goes wrong. With an unencrypted disk worst case I can do a full reinstall and get the data from the old disk.

At the moment I am not even keen to try update-grub without knowing what to do if something goes wrong.
Can anybody point/share some resources ?

$ uname -a
Linux xps15 6.1.21-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Mar 22 21:14:13 UTC 2023 x86_64 GNU/Linux

$ inxi -d -D -L -l -p -S -u -p -v 4
  Host: xps15 Kernel: 6.1.21-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.1 Desktop: Cinnamon v: 5.6.8 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9560 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0YH90J v: A06 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.13.0 date: 12/05/2018

  Message: No logical block device data found.
  Device-1: luks-dff56fa2-6c59-49df-b509-0213de855f5b type: LUKS dm: dm-0
    size: 1.82 TiB Components: p-1: nvme0n1p1
  Local Storage: total: 1.82 TiB used: 813.74 GiB (43.7%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 2TB size: 1.82 TiB
    temp: 35.9 C
  Message: No optical or floppy data found.
  ID-1: / size: 1.79 TiB used: 813.74 GiB (44.4%) fs: ext4 dev: /dev/dm-0
    mapped: luks-dff56fa2-6c59-49df-b509-0213de855f5b label: N/A
    uuid: 8d76dfc3-7472-4a8c-baf7-13452f1688a2
  Processes: 253 Uptime: 20m Memory: 30.92 GiB used: 4.35 GiB (14.1%)
  Init: systemd Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1341
  Shell: Bash v: 5.1.16 inxi: 3.3.26

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.