5.81 gb memory usable out of 8gb

I have recently added a 4gb memory stick with a total of 8gb of memory. But it is showing only 5.81 gb usable. I tried to fix this from bios with the help of some post but couldn’t find the proper option in bios.


How can i use more memory from the reserved ? Any help will be appreciated!

Under Advanced there must be an option to set this…

It can only be set on the BIOS.


Didn’t find any!

Then its not possible. :man_shrugging:

  1. Add more RAM :wink:
  2. Complain to the programmer of the BIOS.
  3. Try this, maybe it has any effect:
amdgpu.vramlimit=1024

Source: drm/amdgpu AMDgpu driver — The Linux Kernel documentation

This should restrict it by 1024MiB by adding it to the kernel parameter at grub.

Can you lead me the way on the 3rd solution! I am a newbie😑.

Ok, then I’ll hold your hand and lead you across the street… :smiley:

  1. Open the grub file:
sudo nano /etc/default/grub

(nano can be also mousepad, gedit, kate or any other editor)

  1. Search for this variable: GRUB_CMDLINE_LINUX_DEFAULT and add there mentioned parameter between the given quotation marks with one space between.
  2. Update the bootloader:
sudo update-grub
# This is the same as above.
sudo grub-mkconfig -o /boot/grub/grub.cfg
  1. Restart and check it again with free -h.


GRUB_CMDLINE_LINUX_DEFAULT=“amdgpu.vramlimit=1024” “quiet apparmor=1 security=apparmor udev.log_priority=3”
like this?

No, not really… This is correct:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 amdgpu.vramlimit=1024"


i have changed the text and upgraded grub. then?
Should i restart or
continue this

“# This is the same as above.
sudo grub-mkconfig -o /boot/grub/grub.cfg”

Dude… when I write “same as above”, what is not understandable?
Here look:

$ cat $(which update-grub)
#! /bin/sh
set -e
exec grub-mkconfig -o /boot/grub/grub.cfg "$@"

i think i get it. i should restart now. job is done.

Nice :+1: So it worked?

Please choose the post which solve the problem to close the thread. :wink:

Dude. You have helped a lot. But unfortunately it didn’t work.
my laptop is not working properly now. It is lagging even loading to the greeter.

1 Like

I removed the vram limit part from the grub. Now it is working as usual again.:sweat_smile: i think we should try something else. I want to thank you again for your patience with me whatever the result.

1 Like

As @megavolt said in the 5.81 gb memory usable out of 8gb - #4 by megavolt he has nothing to advice to you currently. Thanks to him.

How do you think are you alone on the planet with this effect? If you let what probably it is not, than to which point your search and investigations brings your thoughts to? What are possible sources of the that hardware RAM usage? For me it looks like some hardware took that RAM, probably it is manufacturer related question how to setup HW of that notebook to let you use a bit more RAM for an OS level usage. Depending on my experience I am sure that if you install other OS, it will be near the same RAM remaining for OS.

I have iGPU only and configure it in UEFI (so-called an improved version of BIOS) to use as many RAM as it can (1024 MB in my case).
In case of my HW I have 900 MB reserved by some HW, all other RAM is avail. to use in OS. I did not investigate by which HW was reserved that 900MB.

Try to search and to try, post what you find and even tried here. May be for someone it will be a clue to advice somewhat else to try also.

Also, if you will unhide your system information your case could be more understandable by others: [HowTo] Provide System Information
even for you: you can try to do more specific search by your motherboard/notebook model and other HW you use.

Just a thought but if you have onboard graphics wouldn’t it be using apart of the ram as well.

Of course, iGPU uses some system RAM as it’s cache. Network, WiFi, other modules probably also. That “some” is not unveiled: it could be 128 … 2048 MB for iGPU, I didn’t see other cases (in UEFI settings of different PCs).
It is usually configurable, but may be manufacturer hides that settings.

Also, are you having the latest firmware of your PC/notebook? I mean BIOS/UEFI version. But before to update firmware user should read user manual of that action at least twice and after all the operations and their sub sequence is clear/understood, only than to proceed to act.

I remember 1 month old purchase: that was the notebook with AMD Alhlon 3150U CPU inside (modern, but cheapest one, you have the model with more performance (AMD Athlon Gold 3150U vs AMD Ryzen 5 3500U [cpubenchmark.net] by PassMark Software)) and that notebook also has 5.9 or 5.8 GBs of RAM available for OS (for Manjaro LiveCD and for latest Windows 10 installed for him) while there was installed 2 RAM modules by 4 GB each.
So it is not unique case. But it could be not the case of iGPU only.

Before to buy the buyer understands that he want more RAM and did not dive into BIOS settings to change somewhat, and installed 2 * 8GB. Windows 10 shows 13.<something> GB available. So I can’t advice you what exactly to do with BIOS. But you can try (and carefully: to understand and remember what you are changing).

When i was using one stick of 4 gb ram it used to show 3.3 so i thought it will 6.5+ now. Furthermore 2.2 gb is a bit more for igpu. That’s what i thought.:sweat_smile: