21.2pre1: Calamares hangs at 'Configure the hardware'

Hi I’ve attempted to install KDE Plasma Edition of Manjaro a few times now and calamares is just not happy. I always get stuck at 78% and it refuses to continue. I’ve attempted with both free and nonfree drivers and still no luck.

Dropping into terminal and running calamares with -d results in no further errors or anything either just a call to mhdw which reports no errors and stops everything.

CPU: Ryzen 9 3900x
GPU: Nvidia RTX 2080 TI

I can post a full calmares debug log if needed, just request and I’ll go rerun the installer
I likely just missed something in the forum about this being an issue. If so I apologize, I don’t really look here often and was expecting the installer to just work as it always has in the past.


It is a pre-release.
But it could be useful to see more…

(just going to leave this: [HowTo] use public command-line pastebin services without installing anything!)

Thanks for the quick reply!

I figured this was a pre-release via its version number, however Manjaro - Downloads links to this version, perhaps this is a mistake? Additionally when you go to download a archived version you are met with a note that states: The content is for historical reasons, it is archived and unsupported. Installation using an archived ISO may succeed but impossible to update due to ABI changes. Which seems pretty set on having you not download archived versions.

I would personally recommend not having a pre-release be the recommended version, or at least also include a stable download link as well.

Anyways here is the calamares --debug output:

As you can see it simply hangs on the configure the hardware job. No further output or anything:

14:41:51 [6]: virtual Calamares::JobResult Calamares::PythonJob::exec()
    Job file "/usr/lib/calamares/modules/mhwdcfg/main.py" 
    ..  Job description from __doc__ "mhwdcfg" = "Configure the hardware" 
    ..  Running "chroot" ("/tmp/calamares-root-ajbv8h90", "mhwd", "-a", "pci", "free", "0200", "--pmconfig", "/opt/mhwd/pacman-mhwd.conf")

Additionally the live system starts locking up, GUI programs start crashing, etc. Ctrl-C stops working in terminal, it goes crazy xD

OK, it is a pre version, bugs are to be expected. But: why is this version offered for download in a prominent place? The latest final ISO is not so easy to find. I mean, if you want to download the latest ISO right now, you will only get this 21.2 pre. WHY THIS?


Does anyone know what archive version I’m suppose to download for stable. It seems like 20.2.1 maybe?

@HcgRandon @anon71035019

Prerelease here means that our final default settings and apps for each edition are still not final. Software itself should be stable.

So there’s just something wrong with Calamares/hardware here though I’m not sure what exactly.

1 Like

Ah alright I understand. As for hardware I suppose it’s possible something is being funky my side, windows boots and works fine. Any thoughts on where to start looking?

I’ll check the kernal logs, unplug all USB and non essential hardware, and try again.

Only other thing that has changed semi recently is I enabled fTPM in the bios, not sure if that could break things?

I have tried just about everything I can think of to debug this. If anyone else has ideas please let me know.


  • Verify iso checksum
  • Use different USB port
  • Use different USB
  • Re “burn” bootable USB
  • Unplug all external USB devices, except keyboard
  • Run short and long smart tests on target ssd
  • Update bios to latest
  • Reset all bios settings to default
  • Checked dmesg for errors
  • Installed updates prior to running installer.

Nothing I do gets the installer past 78%.

You can also try to install the latest version of Manjaro: 21.1.6.

You can find the links here.

1 Like

Exactly the same thing happening now in 21.2.0 Gnome with non-free drivers and similar mhwd call. 78% in GUI