20-intel.conf makes screen recorders not function

My display is half broken and so i thought making my tab a second display would help me able to see things at full color. I tried achieving this using vdl-monitor and deskcreen. As expected it did work but i soon found out that the screen recorder stopped working. I figured out it was because of the 20-intel.conf file in /usr/share/X11/xorg.conf.d/. I removed it and that did fix the problem but then i wasn’t able to use vdl-monitor. I dont know the reason for the 20-intel.conf glitching out my screen recorder. Heres the content written inside the file:

Section "Device"
    Identifier "intelgpu0"
    Driver "intel"
    Option "VirtualHeads" "2"

And heres my inxi:

  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=875edbad-ad77-49d2-ac56-e609bdfda3a8 rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Portable System: Dell product: Inspiron N5010 v: A02
    serial: <superuser required>
  Mobo: Dell model: 0WXY9J v: A02 serial: <superuser required>
    UEFI-[Legacy]: Dell v: A02 date: 04/09/2010

  Device-1: Intel Core Processor Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0046 class-ID: 0300
  Device-2: Microdia Laptop_Integrated_Webcam_1.3M type: USB
    driver: uvcvideo bus-ID: 1-1.6:3 chip-ID: 0c45:6461 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915
    resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics (ILK) v: 2.1 Mesa 22.1.7
    direct render: Yes

Always can start troubleshooting from here Intel graphics - ArchWiki and let us know what you tried and what failed.
As for the

Might worth checking and/or opening an issue on their project at Issues · dianariyanto/virtual-display-linux · GitHub

Thanks for your help. Turns out it was because of DRI3. I went back to DRI2 by adding the following option to my config file

    Option "DRI" "2"

But now parts of my screen flicker. It said that theres a proper way to disable it with LIBGL_DRI3_DISABLE=1 in mesa but i dont know how to do that. Where do i do this?