1st world problem with i3 community edition

Does anybody know how to get rid of these firefox menu ‘borders’?

What I’ve tried so far:

  • Replacing any ‘000000’ hex values within .Xresources and (i3) config
  • Changing themes
  • Use a compositor (‘solves it’, but it takes away 10-15% of the little pony power I have - so I disabled picom etc.)
  • Set borders in i3’s config to ‘none’/‘pixel 0’
  • Disabling all ‘gaps’ as in ‘i3-gaps’

Black border around the ‘hamburger’ menu:

Solved:

PS: Big THANX @oberon for this great community edition :clap: :clap:

Start here.

1 Like

I tried all ‘default_border’ and ‘default_floating_border’ options, but to no avail.

hide_edge_borders (next paragraph)?

1 Like

Yep, tried that as well - no luck…

EDIT:
for_window [class="firefox"] border pixel 0
Still not playing ball…

Looking again…did you resize that window?

Try this:

Go to $ws2. Open 2 terminals $Mod+enter (x2)

Screenshot.

Moving to Desktops & Window Managers/i3

1 Like

That’s just my ‘gaps’ configuration. You can see the background image in the right bottom corner, but thanx…

Then you’ll need to play with the gaps settings in your config file.

Adding i3-gaps tag

1 Like

It also shows when disabling gaps, but thanx for the suggestion.

Hi, it seems to be a Shadow problem with your compositor.
Try adding this : "class_g = 'firefox' && argb", inside shadow-exclude section of your picom.conf file.

Edit : didn’t reed you already disabled it, but imo it’s not a i3 problem but graphical bug (did you restart X after disabling picom ? What driver did you use for you graphic card ? ).

1 Like

As it seems from the screenshot your in tabbed mode (default binding $mod+w)
So sure it will show these bars so you know what tabs are there and which one is active. Does it also occur when your is split mode (default binding $mod+e)?

If so could you provide your i3 config between ```

thx.

1 Like

I’ve now edited post #1 to read “firefox menu ‘borders’” and a different screenshot in order to avoid further misunderstandings.
These borders appear only on certain dropdowns, the bookmarks dropdown for example doesn’t have a black border.

I see you have changed it.
Nevertheless without the config it is kinda hard to get where this is coming from.

1 Like

I’ve added my i3 config to post #1. It’s basically default setting of the community edition. I only added top gaps for polybar.

1 Like

try this

# i3 config file (v4)
## Look/Theme relevant entries

# set default desktop layout (default is tiling)
# workspace_layout tabbed <stacking|tabbed>

# Configure border style <normal|1pixel|pixel xx|none|pixel>
#set pixel all borders to 0 by default. You can break this rule with per app settings
for_window [class=".*"] border pixel 1

#default_border pixel 1 // removed because of default
#default_floating_border normal // removed because of default

# Hide borders default is none, so only need to set with vertical|horizontal|both|smart 
# hide_edge_borders none 

#for_window [class="firefox"] border pixel 1

# change borders
bindsym $mod+u border none
bindsym $mod+y border pixel 1
#bindsym $mod+n border normal

# Open specific applications in floating mode
for_window [title="alsamixer"] floating enable 
for_window [class="calamares"] floating enable border normal
for_window [class="Clipgrab"] floating enable
for_window [title="File Transfer*"] floating enable
for_window [class="fpakman"] floating enable
for_window [class="Galculator"] floating enable
for_window [class="GParted"] floating enable border normal
for_window [title="i3_help"] floating enable sticky enable border normal
for_window [class="Lightdm-settings"] floating enable
for_window [class="Lxappearance"] floating enable sticky enable border normal
for_window [class="Manjaro-hello"] floating enable
for_window [class="Manjaro Settings Manager"] floating enable border normal
for_window [title="MuseScore: Play Panel"] floating enable
for_window [class="Nitrogen"] floating enable sticky enable border normal
for_window [class="Oblogout"] fullscreen enable
for_window [class="octopi"] floating enable
for_window [title="About Pale Moon"] floating enable
for_window [class="Pamac-manager"] floating enable
for_window [class="Pavucontrol"] floating enable
for_window [class="qt5ct"] floating enable sticky enable border normal
for_window [class="Qtconfig-qt4"] floating enable sticky enable border normal
for_window [class="Simple-scan"] floating enable border normal
for_window [class="(?i)System-config-printer.py"] floating enable border normal
for_window [class="Skype"] floating enable border normal
for_window [class="Timeset-gui"] floating enable border normal
for_window [class="(?i)virtualbox"] floating enable border normal
for_window [class="Xfburn"] floating enable

# browser pop-ups
for_window [window_role="pop-up"] floating enable,move absolute center,border normal
#window_type = normal, dialog, utility, toolbar, splash, menu, dropdown_menu, popup_menu, tooltip and notification
for_window [window_type="splash"] floating enable,move absolute center,border normal
for_window [window_type="tooltip"] floating enable,move absolute center,border normal
for_window [window_role="bubble"] floating enable,border normal
for_window [window_role="task_dialog"] floating enable,border normal
for_window [window_role="Preferences"] floating enable,border normal
for_window [window_type="dialog"] floating enable,border normal
for_window [window_type="menu"] floating enable,border normal
for_window [window_role="Organizer"] floating enable,border normal
for_window [window_role="About"] floating enable,border normal

# Color palette used for the terminal ( ~/.Xresources file )
# Colors are gathered based on the documentation:
# https://i3wm.org/docs/userguide.html#xresources
# Change the variable name at the place you want to match the color
# of your terminal like this:
# [example]
# If you want your bar to have the same background color as your 
# terminal background change the line 362 from:
# background #14191D
# to:
# background $term_background
# Same logic applied to everything else.
set_from_resource $term_background background
set_from_resource $term_foreground foreground
set_from_resource $term_color0     color0
set_from_resource $term_color1     color1
set_from_resource $term_color2     color2
set_from_resource $term_color3     color3
set_from_resource $term_color4     color4
set_from_resource $term_color5     color5
set_from_resource $term_color6     color6
set_from_resource $term_color7     color7
set_from_resource $term_color8     color8
set_from_resource $term_color9     color9
set_from_resource $term_color10    color10
set_from_resource $term_color11    color11
set_from_resource $term_color12    color12
set_from_resource $term_color13    color13
set_from_resource $term_color14    color14
set_from_resource $term_color15    color15

# Theme colors
# class                   border  backgr. text    indic.   child_border
  client.focused          #556064 #556064 #80FFF9 #FDF6E3 #556064
  client.focused_inactive #2F3D44 #2F3D44 #1ABC9C #454948 #2F3D44
  client.unfocused        #2F3D44 #2F3D44 #1ABC9C #454948 #2F3D44
  client.urgent           #CB4B16 #FDF6E3 #1ABC9C #268BD2 #CB4B16
  client.placeholder      #222D31 #0c0c0c #ffffff #222D31 #222D31

  client.background       #2B2C2B

#############################
### settings for i3-gaps: ###
#############################

# Set inner/outer gaps
gaps inner 14
gaps outer -2
gaps top 20

# Additionally, you can issue commands with the following syntax. This is useful to bind keys to changing the gap size.
# gaps inner|outer current|all set|plus|minus <px>
# gaps inner all set 10
# gaps outer all plus 5

# Smart gaps (gaps used if only more than one container on the workspace)
#smart_gaps on

# Smart borders (draw borders around container only if it is not the only container on this workspace) 
# on|no_gaps (on=always activate and no_gaps=only activate if the gap size to the edge of the screen is 0)
smart_borders on

It is also kinda double to set a default border and then also the same setting per app.

1 Like

I tried the configuration for browser pop-ups first, but unfortunately that didn’t do it. I then tried
for_window [class=".*"] border pixel 0
and
for_window [class=".*"] border pixel 1
and also commented out
# hide_edge_borders none
but the border’s still showing.

I’ll play around more with the browser window types and see what gives.

Thanx

1 Like

Hello could you try this :
in firefox type about:config in url and the in search bar type : layers.acceleration.force-enabled.
If it’s set to false, set it to true, then restart firefox, and did it again to set it to false then restart firefox.

Let me know if it solve your problem.

3 Likes

Thanx alot, that did the trick. I must have set it to ‘true’ while hardening my profile.

Also thank you to everyone trying to fix it.

One 1st world prob less…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.