1366x768 resolution doesn't work

Hi, I am a new GNU/Linux user and installed Manjaro KDE a few days ago. The problem I have is that I have a very old 19 inch monitor with 1366x768 resolution that only supports VGA output and is connected to my Radeon graphics card via VGA-to-DVI-1 adapter (might be relevant, I dont know).

The maximum resolution in settings by default is 1024x768. After a few searches I found a solution and created a bash script to autostart

#!/bin/sh

xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

xrandr --addmode DVI-1 1368x768_60.00

xrandr --output DVI-1 --mode 1368x768_60.00

But the problem is that the resolution here is 1368x768 and NOT the 1366x768. I got the values from the cvt 1366 768 60 command which for some reason gives the output for 1368x768

# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

What should the values be for the correct 1366x768 resolution? I calculated the PPI for my monitor to be 82.48 based on the fact it is 19 inch. I tried calculating other values based on the aspect ratio but when I applied the mode monitor was unable to process the output and I had to restart, not sure if I made a mistake somewhere. What are the other values for screen resolutions should be?

As it is, on the current resolution the edges of applications in fullscreen are cut off by a few pixels which is workable but not great. I had mostly no issues with screen resolution on windows 10 after initial drivers install and update.

Also, when I use the script, on each reboot the first login screen is in 1024x768 resolution (obviously because the script haven’t ran yet), is there a way to apply the resolution before that?

Try this one:

Modeline "1366x768" 85.500 1366 1494 1624 1798 768 770 776 795 +hsync -vsync

Have a look here:
https://wiki.archlinux.org/title/xrandr#Permanently_adding_undetected_resolutions

1 Like

Thank you for your help, your parameters worked perfectly.

Another question is what do I put in the Device -> Driver section in the /etc/X11/xorg.conf.d/ config from the archwiki you mentioned xrandr - ArchWiki ?

I use amd open source drivers


Should I put video-linux, amdgpu or radeon in the Device -> Driver section of the config file?

amdgpu

Also check if you don’t already have a config file in the conf.d folder…
(Don’t know if mhwd is doing anything in that respect)

btw. In case you mess up and get a black screen or so, switch to TTY (CTRL+ALT+F3 for example), log in and fix / remove the config file… :wink:

1 Like

When I tried to use the full /etc/X11/xorg.conf.d/ config, system didn’t want to boot

Section "Monitor"
    Identifier "DVI-1"
    Modeline "1366x768_60.00"  85.50  1366 1494 1624 1798  768 770 776 795 -hsync +vsync
    Option "PreferredMode" "1366x768_60.00"
EndSection


Section "Screen"
    Identifier "Screen0"
    Monitor "DVI-1"
    DefaultDepth 24
    SubSection "Display"
        Modes "1366x768_60.00"
    EndSubSection
EndSection

Section "Device"
    Identifier "Device0"
    Driver "amdgpu"
EndSection

Thanks for the tip on ctrl+alt+f3 :smiley:

When I removed the Screen and Device sections, system booted but with default resolution of 1024x768 :frowning:

Check the logs and try to figure out what goes wrong /var/log/Xorg...

Can you post the output of inxi -Fazy ?

inxi -Fazy output:

ystem:
  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c8b2b200-dc93-47c7-b794-4352bf238d18 rw quiet udev.log_priority=3 
  Console: tty pts/2 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux 
  base: Arch Linux 
Machine:
  Type: Desktop Mobo: MSI model: H81M-P33 (MS-7817) v: 1.0 serial: N/A 
  UEFI: American Megatrends v: 1.4 date: 02/20/2014 
CPU:
  Info: Quad Core model: Intel Core i5-4570 socket: BGA1155 bits: 64 type: MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: 
  L1: 256 KiB L2: 6 MiB L3: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25608 
  Speed: 2073 MHz min/max: 800/3600 MHz base/boost: 3200/3800 volts: 1.2 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 2073 2: 3004 3: 1739 4: 2212 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] 
  vendor: PC Partner Limited driver: radeon v: kernel alternate: amdgpu 
  bus-ID: 01:00.0 chip-ID: 1002:6798 class-ID: 0300 
  Display: server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: DVI-1 res: 1366x768 hz: 60 
  OpenGL: renderer: AMD TAHITI (DRM 2.50.0 5.10.42-1-MANJARO LLVM 12.0.0) 
  v: 4.5 Mesa 21.1.2 direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:8c20 class-ID: 0403 
  Device-2: AMD Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 1002:aaa0 class-ID: 0403 
  Device-3: C-Media Storm Pro type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:3 chip-ID: 0d8c:0012 
  class-ID: 0300 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 715.29 GiB (38.3%) 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G 
  family: Driven SSDs size: 223.57 GiB block-size: physical: 512 B 
  logical: 512 B sata: 3.2 speed: 6.0 Gb/s rotation: SSD serial: <filter> 
  rev: J4.3 temp: 32 C scheme: GPT 
  SMART: yes state: enabled health: PASSED on: 68 hrs cycles: 30 read: 50 GiB 
  written: 177 GiB 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD10EZRX-00D8PB0 
  family: Green size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  sata: 3.0 speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0A80 
  temp: 38 C scheme: GPT 
  SMART: yes state: enabled health: PASSED on: 5y 214d 8h cycles: 1806 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Cruzer Fit 
  size: 14.91 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 scheme: GPT 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Western Digital 
  model: WD Elements 1042 drive model: WD7500BMVW-11S5XS0 
  family: Elements / My Passport (USB, AF) size: 698.63 GiB block-size: 
  physical: 4096 B logical: 512 B sata: 3.0 speed: 3.0 Gb/s rotation: 5400 rpm 
  serial: <filter> drive serial: <filter> rev: 1007 drive rev: 01.01A01 
  temp: 38 C scheme: MBR 
  SMART: yes state: enabled health: PASSED on: 1y 300d 1h cycles: 2987 
Partition:
  ID-1: / raw-size: 223.27 GiB size: 218.71 GiB (97.96%) 
  used: 20.84 GiB (9.5%) fs: ext4 block-size: 4096 B dev: /dev/sda2 
  maj-min: 8:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 40.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 200 Uptime: 29m wakeups: 0 Memory: 7.72 GiB 
  used: 2.72 GiB (35.2%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: pacman: 1424 lib: 441 flatpak: 0 Shell: Bash (sudo) 
  v: 5.1.8 running-in: konsole inxi: 3.3.04 

Then try radeon instead of amdgpu in the device / driver section.

Or you might want to try using amdgpu instead of radeon:

Enable Southern Islands (SI) and Sea Islands (CIK) support

1 Like

radeon option for Driver worked. Thank you for your help :smiley:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.