12700KF stuttering with e-cores enable!

Hey there,
i got a problem with my 12700KF in Manjaro.

Most Games are stuttering while e-cores are enable - if i disable e-cores the problem is gone.
So i guess, e-cores are known by the kernel, but they are not used properly?
Is there information if they will be usable in future? Is this a kernel-thing or do i need to change distro?

i7 12700KF
64GB DDR4 3000
Samsung 970 evo plus
AMD RX6800
Manjaro kernel 6.5.5-1

Dragon of Luck

Is the gamemode service running?

 systemctl --user status gamemoded.service

If not, install it and start/enable it as user.

pamac install gamemode
systemctl --user enable --now gamemoded.service

I guess for such CPU’s “SCHED_ISO” (SchedulingPolicies) is important, which is triggered by this gamemode service when you run a game. It is a “soft realtime policy” for the cpu, which should priorities the P-Cores.

EDIT: I forgot you need to run the game with: gamemoderun <command> or in steam gamemoderun %command%. :wink:

I’m not an Intel user so have no idea about the state of e-core scheduling on Linux, but if you mean Wine/Proton games then an easy fix should be to set the WINE_CPU_TOPOLOGY environment variable in /etc/environment. E.g.


means only use the 8 cores numbered 0-7. Use lstopo -p from the hwloc package to find the correct numbers for the 8 p-cores, they might not be 0,1,2,3,4,5,6,7.