1080p 60fps stream playback


I have a Toshiba L655-S5155 I’ve been upgrading and using to learn Linux on.

I upgraded the processor in it a while ago from the p6200 to an i5-560m in hopes the device would handle 1080p video playback better. However it hasn’t helped.

I watch Twitch streams through streamlink, streamlink twitch gui and mpv.

720p 60fps seems fine however 1080p 60fps drops frames. I have it plugged into a 1080p TV through HDMI.

Stacer says cpu usage is only going to %50 max while it’s playing a stream. It’s the same in the Brave browser.

I’ve read this forum post however I’m unsure if it’d help me or not.

I removed the light-locker package due to it locking my laptop when I close the lid. The backlight turns off but I’m pretty sure the screen is still rendered. Maybe that is the issue?

Nonetheless I have the output from the inixi and tlp-stat command found in that post.

  Kernel: 5.11.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=2a86e105-1e12-4ddb-9fb7-5d803efea2af rw quiet udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: TOSHIBA product: Satellite L655 v: PSK2CU-0QU01U 
  serial: <filter> 
  Mobo: Intel model: N/A serial: <filter> BIOS: INSYDE v: 2.80 
  date: 07/03/2012 
  ID-1: BAT1 charge: 3.8 Wh (88.4%) condition: 4.3/4.2 Wh (101.9%) volts: 12.3 
  min: 11.9 model: LGC PA3817U-1BRS type: Li-ion serial: N/A status: Charging 
  cycles: 1 
  Info: Dual Core model: Intel Core i5 M 560 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7 cache: 
  L2: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21285 
  Speed: 2217 MHz min/max: 1199/2667 MHz boost: enabled Core speeds (MHz): 
  1: 2217 2: 1200 3: 1273 4: 1926 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Core Processor Integrated Graphics vendor: Toshiba 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300 
  Device-2: Chicony CNF9055 Toshiba Webcam type: USB driver: uvcvideo 
  bus-ID: 2-1.1:3 chip-ID: 04f2:b1d6 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.10 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1848 s-dpi: 96 s-size: 508x489mm (20.0x19.3") 
  s-diag: 705mm (27.8") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.0.1 
  direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.10-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 5000 
  bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR8152 v1.1 Fast Ethernet vendor: Toshiba 
  driver: atl1c v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 1969:2060 
  class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 2-1.6:5 chip-ID: 8087:07dc class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 585 GiB used: 49.51 GiB (8.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: OCZ model: VERTEX4 size: 119.24 GiB 
  block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: SSD 
  serial: <filter> rev: 1.5 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS725050A9A364 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: C72E scheme: MBR 
  ID-1: / raw-size: 119.24 GiB size: 116.81 GiB (97.96%) 
  used: 22.82 GiB (19.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 60.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 187 Uptime: 18m wakeups: 1 Memory: 3.64 GiB 
  used: 1.44 GiB (39.4%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 979 lib: 277 Shell: Bash v: 5.1.0 
  running-in: xfce4-terminal inxi: 3.3.03


--- TLP 1.3.1 --------------------------------------------

+++ Processor
CPU model      = Intel(R) Core(TM) i5 CPU       M 560  @ 2.67GHz

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = schedutil
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = conservative ondemand userspace powersave performance schedutil 
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =  1199000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  2667000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies = 2667000 2666000 2533000 2399000 2266000 2133000 1999000 1866000 1733000 1599000 1466000 1333000 1199000 [kHz]

/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = schedutil
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = conservative ondemand userspace powersave performance schedutil 
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =  1199000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  2667000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies = 2667000 2666000 2533000 2399000 2266000 2133000 1999000 1866000 1733000 1599000 1466000 1333000 1199000 [kHz]

/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = schedutil
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = conservative ondemand userspace powersave performance schedutil 
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =  1199000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  2667000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_frequencies = 2667000 2666000 2533000 2399000 2266000 2133000 1999000 1866000 1733000 1599000 1466000 1333000 1199000 [kHz]

/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = acpi-cpufreq
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = schedutil
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = conservative ondemand userspace powersave performance schedutil 
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =  1199000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  2667000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_frequencies = 2667000 2666000 2533000 2399000 2266000 2133000 1999000 1866000 1733000 1599000 1466000 1333000 1199000 [kHz]

/sys/devices/system/cpu/cpufreq/boost                  = 1

Intel EPB: unsupported CPU.

/sys/module/workqueue/parameters/power_efficient       = Y
/proc/sys/kernel/nmi_watchdog                          = 0


Better? Yes, but damn that’s an old CPU, not to mention that you’re using 4GB DDR3 RAM, which is a lot slower.

You only have 4GB RAM, you should create a swapfile of at least 8GB. This will help your computer run better.

I don’t know if your CPU would even support hardware acceleration because of how old it is. If it did, I’d recommend using Firefox with HW Acceleration.

Yes it’s old, but cheaper than buying a new system76 laptop. Not as good, but cheaper for sure.

I recently added an old SSD to the system and re-did the Manjaro install. I had a swap partition of 8gb when it was installed on the HDD and had the same issue. Even with the new processor. However I misread and you said swapfile. I’ll try this.

I was looking into buying different ram modules. The laptop can support 8gb officially, though I’ve seen YouTube videos of people using 16gb. This was the ram kit I was looking at. Slightly higher clock speed too. I’d rather not dump the money on it though.

I’ll look into trying LibreWolf instead of Brave and double check to make sure HW Acceleration is on providing its even supported. As well as creating a swapfile.

Thanks for the info!

Honestly, I wouldn’t really upgrade that laptop any further. You can get a used Thinkpad that is way better for around $100-300. Some that even comes with an SSD by default as well as upgradable RAM & storage. Even better if you can find a laptop that supports Libreboot

Your i5-560m only supports DDR3 800/1066Mhz

More ram will not help you having better playback.
It’s just 4Go could be short depending of your running processes.
8 Go as swapfile is way too much, unless you run several virtual guests or some tasks requiring lot of memory, but i doubt your cpu could afford them.

Anyway, if you did not have OOM (while you had no swap file) means you have enough ram even if you have not much.
Now you have swap, you can decrease your swappiness to something like 30 or 20.

What about playing youtube video in 1080p ? Are you able play them well? How much is your cpu usage ?

Sure you can try to do what they say in the other thread to have hw decoding (with chromium or firefox), but not sure your cpu can support it.

I really don’t like this kind of advices :" Trash your computer and buy another one…"

Sorry mate, but maybe the OP can try alternate solutions.
At the end, if he realizes this is the better option, why not.
But definitely not a first option we should provide him.

Stacer says 65-75% on Brave fullscreen. Has the same problem as streamlink. 720p60 is absolutely fine though and seems I’ll have to settle for that. Though stats for nerds says it’s dropping frames but it isn’t noticeable.

I was looking at Thinkpads on eBay but was unsure as to what model to get. Not to mention I already had and now upgraded this Toshiba considerably. I was shocked to see the CPU mounted in a socket (G1) when I took it apart last year to re-do the thermal paste.

Did some research and found you can upgrade it. The HM55 chipset can use up to an i7-640m. However they’re pricey and I likely wouldn’t get the full boost speed. With this i5 I only get 2.850mhz when I should see around 3.2. Likely some hardware limitation somewhere. Or a setting I don’t have set in Manjaro. I haven’t done a test though since the reformat.

I have some sentimental value to this laptop since it was my friends and its similar to my first laptop (which I still have) a Toshiba Satellite L505D. However this ones specs are much better than the L505D and it’s in better condition too.

All I need now to finish it is some paint and clear coat. I ordered some stickers from eBay I want to put on but holding off until I do the paint job lol. Here’s some pics.

1 Like

Who said this?

All I said was: “Honestly, I wouldn’t really upgrade that laptop any further”, and also gave options IF they want it, because it could cost more to constantly upgrading that laptop further and further, but not really get much improvement.

And they listed RAM from Amazon that is 1600 Mhz and mentioned that it’s a slightly higher clock than their current one, so I mentioned that their CPU only support DDR3 800/1066MHz

Yeah, the difference between i5-560m and i7-640m isn’t much. They are both 2 cores / 4 threads as well. I don’t personally know if the slightly higher base and turbo clock will make a huge difference on that generation’s of CPUs.

Note that although it says 3.20GHz turbo boost, it means on 1 core. But if you’re using 2 cores at a time, it’s reduced.

Just for future references, Arch Wiki has a list of which models work if you’re ever interested in the future! Though some might be missing from the list.

Also, I am curious, have you tried to run Windows on this laptop to see if 1080p 60fps works?

That being said, I had a laptop slightly better than yours (1 or 2 generation i5 CPU newer than yours) and I had issues on Windows watching 1080p on YouTube. 720p worked great though.

Edit: Oh, I forgot to mention,

you might not be using 100% CPU for watching streams because there is no hardware acceleration.

No I have not and I considered this. I think I’ll work on that now. I can easily change up the partition with gparted on the spare HDD for a couple 50gb ntfs partitions. Have one for 10 and the other for 7 to test things on. I was quite pleased to see this application run on a win 7 partition a few months ago I made with C# wpf.

The 560m was the best choice I feel to upgrade from the p6200. On this site it shows its a 53.5% increase from their benchmarks. It seems a bit quicker launching apps but not by much. Least it worked, was good to mess around with.

I added the swap file*. It helps it a little on its initial boot loading the desktop environment. However nothing in terms of 1080p 60fps streaming. Going to setup windows now.


@realmain Come on, be honest, that is what you meant

I think the OP really do not care about libreboot though, and he said it, his laptop has a sentimental value…


You could start with doing some research about which video codec your streaming platform use.
Then, install libva-utils from Manjaro repo, and do: vainfo in console to see what you get.

You should follow this :

and this one :

or this one depending of the browser you use


Be careful, because there are a lot of small details, as setting env variables. If you miss one thing, you couldn’t get a good result.

After a long process that I figured would be easy. Turns out windows makes no difference. Well it seems slightly smoother, but it stutters. It’ll play fine for 5 seconds and then freeze for a second. Then resume.

Getting it all back together, had to take it apart some.

Here is the output of the vainfo command.

vainfo: VA-API version: 1.11 (libva 2.11.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Ironlake Mobile - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc

Pretty sure I’ll just have to settle for 720p60 which is fine by me. A little pixelated but pretty decent for a laptop that’s a decade year old. Reading the documentation @yannssolo sent, I’m fairly certain the correct version of that software is installed and configured. Maybe the output I listed will help.


Your CPU can decode h264 video, so if the video format of the streaming platform you use, use it too, that should be ok. Therefore, you have to force playboack to that format.

I tried forcing it to h264 but no difference. I used the --ffmpeg-video-transcode h264 flag when launching streamlink through the terminal. No change. By default streamlink says it’s set to copy. Whatever that means.

Unfortunately I’m thinking it’s just the CPU being too old. A friend of mine will be giving me some ram for the laptop in a few months. Suppose I’ll see then if that makes a difference but I still have doubts.