0AD not launching

Hi,
Just today I tried launching 0AD, but I wouldn’t work, it seem to launch but it disappeared before opening. It has been a while since I last launched it, but the last time it worked fine, but it might have been an update.

I tried reinstalling both, the 0ad and the 0ad-data packages, but it still wouldn’t work.

When launching from the terminal, to see if it provided some useful info, I don’t see anything useful for me:

TIMER| InitVfs: 309.627 us
Writing the mainlog at /home/iago/.config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 1.69187 ms
Sound: AlcInit success, using OpenAL Soft
Assertion failed: "ret == 0"
Location: lcpu.cpp:174 (os_cpu_SetThreadAffinityMask)

Call stack:

(0x55e05a658e7c) /usr/bin/pyrogenesis(+0x503e7c) [0x55e05a658e7c]
(0x55e05a6333bb) /usr/bin/pyrogenesis(+0x4de3bb) [0x55e05a6333bb]
(0x55e05a632eaf) /usr/bin/pyrogenesis(+0x4ddeaf) [0x55e05a632eaf]
(0x55e05a6336f3) /usr/bin/pyrogenesis(+0x4de6f3) [0x55e05a6336f3]
(0x55e05a6589e9) /usr/bin/pyrogenesis(+0x5039e9) [0x55e05a6589e9]
(0x55e05a658d8b) /usr/bin/pyrogenesis(+0x503d8b) [0x55e05a658d8b]
(0x55e05a682b0c) /usr/bin/pyrogenesis(+0x52db0c) [0x55e05a682b0c]
(0x55e05a68284c) /usr/bin/pyrogenesis(+0x52d84c) [0x55e05a68284c]
(0x55e05a682a9d) /usr/bin/pyrogenesis(+0x52da9d) [0x55e05a682a9d]
(0x55e05a652e9e) /usr/bin/pyrogenesis(+0x4fde9e) [0x55e05a652e9e]
(0x55e05a68284c) /usr/bin/pyrogenesis(+0x52d84c) [0x55e05a68284c]
(0x55e05a652c0d) /usr/bin/pyrogenesis(+0x4fdc0d) [0x55e05a652c0d]
(0x55e05a39386c) /usr/bin/pyrogenesis(+0x23e86c) [0x55e05a39386c]
(0x55e05a3840e7) /usr/bin/pyrogenesis(+0x22f0e7) [0x55e05a3840e7]
(0x55e05a1a1a37) /usr/bin/pyrogenesis(+0x4ca37) [0x55e05a1a1a37]
(0x55e05a1a013b) /usr/bin/pyrogenesis(+0x4b13b) [0x55e05a1a013b]

errno = 22 (Invalid alignment)
OS error = ?

After searching, the only issue that I can find that is similar is this one.

What could it be? Is it probable that I broke some config or package on the system or is it likely an update problem that should be fixed?

I could find any answers to that in 0AD developer platform.

Thanks

Perhaps that log has more information.

Hi, thanks for replying

image
Apart from those two lines that show an error, the entire log is just logging every setting being loaded, and I can’t find anything that could be an error.
I can’t upload my logs here, but as I’ve seen, taking out the two lines I’ve just mentioned, is line by line the same as the logs uploaded to the link I mentioned on the first post, with the only thing changing being the hardware info printed out, but I don’t think that is where the error comes from.

Thanks

Perhaps. There are some 0ad-directories local to the user:

$ find . -type d -iname 0ad
./.local/share/0ad
./.cache/0ad
./.config/0ad

You can try to remove the $HOME/.cache/0ad one and rename the $HOME/.config/0ad to start with a fresh config.
The bug report you found seems fitting even though the version doesn’t quite match (a25.b-6 vs currently a25.b-8) and showed even the packager could reproduce the crash but apparently no further findings have been published :man_shrugging:

Hi,
I just tried doing what you said, but I didn’t work.
I had already deleted the config directory to see if that was the problem before opening the thread, and now moved the newly generated one and deleted the cache folder, but didn’t do anything either.
Thanks for helping me out, I’ll wait to see if with an update it is fixed, as I don’t think this problem is worth more time, but thanks.
Whenever is updated, I’ll post here my update with the error.

Thank you very much. Delthia

1 Like