0 AD reboots system when launched

When I launch 0ad (the strategy game) my systems reboots. Sort of like a quick reboot but the game never starts. Please help. What output must I add to help you help me and how do I add it.

  Kernel: 5.13.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=e5318d21-2f3e-4c85-8f36-4da3e5717ca9 rw quiet loglevel=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: EndeavourOS base: Arch Linux 
  Type: Laptop System: LENOVO product: 20236 v: Lenovo G500 serial: <filter> 
  Chassis: type: 10 v: Lenovo G500 serial: <filter> 
  Mobo: LENOVO model: INVALID v: 31900004Std serial: <filter> UEFI: LENOVO 
  v: 78CN19WW(V1.07) date: 07/04/2013 
  ID-1: BAT1 charge: 35.6 Wh (100.0%) condition: 35.6/40.4 Wh (88.1%) 
  volts: 12.0 min: 10.8 model: LENOVO PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
  RAM: total: 7.63 GiB used: 1.82 GiB (23.9%) 
  RAM Report: 
  missing: Required tool dmidecode not installed. Check --recommends 
  Info: Dual Core model: Intel Core i3-3120M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  cache: L2: 3 MiB bogomips: 19962 
  Speed: 1285 MHz min/max: 1200/2500 MHz Core speeds (MHz): 1: 1285 2: 1878 
  3: 1647 4: 1348 
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept 
  erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm 
  lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe 
  pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp 
  rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt 
  xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
  Device-2: Realtek Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 3-4:2 
  chip-ID: 0bda:5728 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.org 1.20.13 compositor: kwin_x11 driver: 
  loaded: intel unloaded: fbdev,modesetting,vesa 
  resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-arch1-1 running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: no 
  Device-1: Qualcomm Atheros AR8162 Fast Ethernet vendor: Lenovo driver: alx 
  v: kernel port: 2000 bus-ID: 01:00.0 chip-ID: 1969:1090 class-ID: 0200 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Broadcom BCM43142 802.11b/g/n vendor: Lenovo driver: wl v: kernel 
  port: 2000 bus-ID: 02:00.0 chip-ID: 14e4:4365 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Foxconn BCM43142A0 Bluetooth module type: USB driver: btusb v: 0.8 
  bus-ID: 1-1.3:4 chip-ID: 105b:e065 class-ID: fe01 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled 
  rfk-block: hardware: no software: yes address: see --recommends 
  Permissions: Unable to run lvs. Root privileges required. 
  Message: No RAID data found. 
  Local Storage: total: 465.76 GiB used: 41 GiB (8.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD5000LPVT-24G33T1 size: 465.76 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 
  scheme: GPT 
  Optical-1: /dev/sr0 vendor: PLDS model: DVD-RW DS8A9SH rev: EL3A 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 34.33 GiB (35.1%) 
  fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A 
  uuid: e5318d21-2f3e-4c85-8f36-4da3e5717ca9 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 316 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 4121-1DC1 
  ID-3: /home raw-size: 229.15 GiB size: 224.49 GiB (97.97%) 
  used: 6.67 GiB (3.0%) fs: ext4 dev: /dev/sda8 maj-min: 8:8 label: N/A 
  uuid: 1b122c7a-021c-4ec5-b272-87d9c72f0566 
  Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100) 
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: 6f65a16f-2413-40df-9e78-7f248cc8df0e 
  ID-1: /dev/sda1 maj-min: 8:1 size: 99.49 GiB fs: <superuser required> 
  label: N/A uuid: 6828A96428A931CC 
  ID-2: /dev/sda13 maj-min: 8:13 size: 32 GiB fs: <superuser required> 
  label: N/A uuid: 85651370-f7ea-43a4-847d-a77bd24a4494 
  ID-3: /dev/sda2 maj-min: 8:2 size: 516 MiB fs: <superuser required> 
  label: N/A uuid: 4E78B74478B7299B 
  ID-4: /dev/sda3 maj-min: 8:3 size: 100 MiB fs: <superuser required> 
  label: N/A uuid: 52AE-8B20 
  ID-5: /dev/sda4 maj-min: 8:4 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 1-1.2:3 info: Maxxter Wireless Receiver type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 50mA 
  chip-ID: 248a:8566 class-ID: 0301 
  Device-2: 1-1.3:4 info: Foxconn BCM43142A0 Bluetooth module type: Bluetooth 
  driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 105b:e065 
  class-ID: fe01 serial: <filter> 
  Device-3: 1-1.4:5 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129 
  class-ID: ff00 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-4:2 info: Realtek Lenovo EasyCamera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:5728 
  class-ID: 0e02 serial: <filter> 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 54.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 178 Uptime: 56m wakeups: 1 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1154 lib: 262 flatpak: 0 
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.05```

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. starting the game in a console and see if you can see something there before it reboots?


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

1 Like

Hi. Thanks a million. Please tell me what else you need. When I run it from console the same happens, but I tried a the game a while back on this same laptop on Elementary OS and the game worked fine. Your help will really be appreciated. Ps. I just ried it on Endeavouros and the same thing happens. The output is from Endeavouros. Manjaro is my main installation so I don’t want to mess around there really.

Do you have a compelling reason to be on the 5.13 Stable development kernel for a

So please read this:

Especially the section Linux has multiple kernels I just linked to and then install an LTS kernel and boot into that.

Also, your UEFI firmware is really old. Refer to your manufacturer’s hardware guide how to update that.

Start there and then we’ll see if we need to dig any deeper (or not)


1 Like

Thanks buddy. I switched to the LTS kernel and the game works fine. Last question. I downloaded some auto update package from Lenovo website to update the firmware and it just tell me there is nothing available for my laptop. Any idea on how else I can manually update the UEFI firmware on this laptop? Ps. I thought since this is a rolling release I better stay on the latest kernel to be up to date. Stupid of me.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)


In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I don’t have the same hardware as you, so that’s why I referred you to your manufacturer’s manual / web-site / forum. :sob:

Not stupid: you read that bit of the tutorial and now you know more, so I’m recommending you read it all except the bits where it says to come back later…


Glad we could help, but why are you not asking in EndeavourOS forum when you using their distro?


Manjaro is my main distro, I just installed the game there to see if it will have the same problem and it did. Thanks a million for all the help guys.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.