Zyxel nsa320s access

I’m new to Manjaro but have used linux in the past but I’m having an issue with accessing my Zyxel nsa320s with cifs and smb
I’ve tried every command I could find on the forum here and on the web but to no avail.
I’m on Manjaro lxde.
So, the nas is an old thing and it uses smb1 protocol so I tried with ports 139 and 445, I’ve tried mount.cifs commands to access a share on it that is open to everyone and doesn’t have a user/password, mount -t cifs //ip address/share, tried to use smb4k and I’m at a loss.
Been at this for 4 long hours and I finally figured I needed some help so here I am.

mount -t cifs // /mnt/nsa320s -o username=myuser,password=mypass,
After running the above command I get a:

Hopefully someone has experience with old nas devices. Although I’d like for it to work it’s not a deal breaker, I’m staying with Manjaro.

There is a heap of issues on the archived forum from when upstream samba disabled smb1.

Something like this in your client smb.conf archived forum comment

    server min protocol = NT1

If you get a prompt then you are having special chars interpreted by the mount command delimiters or another reserved character.

try surrounding your username and password with single qoutes like this

... -o username='myuser',password='mypass' ...

And yes you can make it work

1 Like

workgroup = WORKGROUP
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client min protocol = SMB2
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*
pam password change = yes
map to guest = Bad Password
usershare allow guests = yes
name resolve order = lmhosts bcast host wins
security = user
guest account = nobody
usershare path = /var/lib/samba/usershare
usershare max shares = 100
usershare owner only = yes
force create mode = 0070
force directory mode = 0070
client max protocol = smb3
server min protocol = NT1

comment = Home Directories
browseable = no
read only = yes
create mask = 0700
directory mask = 0700
valid users = %S

comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
guest ok = no
read only = yes
create mask = 0700

comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no[/code]

That’s my smb.conf. I had already added the NT1 part that I found somewhere else but it didn’t help. Have you got any other ideas?
I’ve browsed the archived forum but I can’t seem to find anything that relates to my problem.

On a seperate note I’ve uninstalled pcmanfc that came with lxde and gone with dolphin instead.

PS: linux-aarhus? From DK?

yup :slight_smile: Denmarks capitol number two :slight_smile:

Vejle here :slight_smile: but we’d better keep it in english if I get this figured out and others find it useful, they won’t have much use for it in danish.

I’ve tried adding this line to my fstab:

// /mnt/share cifs ver=1.0 username='user',password='pass' 0 0

but that doesn’t make me able to mount my shares with

sudo mount -a

Any ideas? When trying to access the nas I always hear it spinning up but not on this machine… nothing happens so it’s as if it doesn’t even connect