Zsh problem not working

hi there,
i installed zsh earlier and found some config files laying around in my home directory and i removed them… after quitting the terminal and opening it again my zsh was not able to open so i tried to uninstall and install it back again … so when i tried to uninstall it it showed me this error …

checking dependencies... error: failed to prepare transaction (could not satisfy dependencies) :: removing zsh breaks dependency 'zsh' required by manjaro-zsh-config :: removing zsh breaks dependency 'zsh' required by zsh-autosuggestions :: removing zsh breaks dependency 'zsh' required by zsh-completions :: removing zsh breaks dependency 'zsh' required by zsh-history-substring-search :: removing zsh breaks dependency 'zsh>=4.3.9' required by zsh-syntax-highlighting :: removing zsh breaks dependency 'zsh' required by zsh-theme-powerlevel10k

so i unistalled every single package one by one and uninstalled zsh …
and when i install it again its like this

`This is the Z Shell configuration function for new users,
zsh-newuser-install.
You are seeing this message because you have no zsh startup files
(the files .zshenv, .zprofile, .zshrc, .zlogin in the directory
~). This function can help you with a few settings that should
make your use of the shell easier.

You can:

(q) Quit and do nothing. The function will be run again next time.

(0) Exit, creating the file ~/.zshrc containing just a comment.
That will prevent this function being run again.

(1) Continue to the main menu.

— Type one of the keys in parentheses --`

I thought zsh is the default shell for Manjaro editions already?


This is perfectly normal when a user installs zsh for the first time with no config files.

I don’t understand what problem you are having?

its bash actually

Not all, KDE have bash, Gnome have zsh, I don’t know other.

i use kde

You should probably not have removed these, as they are the configuration files which make using the shell easier and assist in it’s usage.
You can find them (the Manjaro preconfigured defaults) in a subdirectory of /etc/skel
and just copy them back to your $HOME directory
where you removed them from.

Or you can run trough the configuration wizard that you have seen to configure it to your liking.

Ah didn’t realized. I just checked the iso profiles, KDE & XFCE uses bash. GNOME & a lot of community editions use zsh

thanks i’ll try that and let you know

thank you a lot its working now

tip:
if you don’t know what things are for and you want to remove them anyways
don’t remove them - but just move them to a different place - like backup
or copy them there and then delete from the original place
That way you can always undo what you did …
In this case it was easy as the “backup” already existed in /etc/skel …

1 Like

ill do that next time

I’m sure you will … :wink:

1 Like