Zsh looks weird


It seems that after the update zsh began to look strange. There are no icons and, before my attempts to restore it, there was a full path to the left, where the house usually stands if you just entered it.
I tried to delete the ./.zshrc settings file and now it looks even weirder and there are no history hints that are displayed if a similar command has already been entered.
It is not possible to reinstall it from pacman, there are problems with dependencies. Therefore, until I tried to delete it through the console…

Such as? Please post the command and full output you ran using preformatted text.

Either way, make sure you’re fully up to date and have reviewed the latest Announcements post.

I went into the virtual machine on which the same operating system was installed and copied the files from there: .zhistory, .zshrc.
Now I have a history saved. But he still looks strange. I have the font needed for the icons installed

command example:

any command
cd /home

Any of the possible commands that you just came up with. It doesn’t matter in this case. Nothing worked.

No, I meant the command you used to update / reinstall.

the update was via Pacman, as usual. I didn’t do anything special in the console about this. everything worked normally.
I tried to remove it via Pacman, but due to an error with dependencies, I did not remove it. I haven’t tried deleting it through the console yet, to, for example, try to restore the normal state of the program.

I’ve already asked you for the output. Help us help you.

Delete what?

could not satisfy dependencies:
- removing zsh breaks dependency 'zsh' required by manjaro-kde-settings

message from Pacman
«Delete what?»
I haven’t tried deleting it through the console yet (ZSH), to, for example, try to restore the normal state of the program.

By the way, have you rebooted since you updated? Please do so if you haven’t already.

If the issue still persists, please post your ~/.zshrc and ~/.p10k.zsh using a pastebin service and link them here.

I don’t think he has one anymore. :smiley:

Yes, I have already rebooted the computer several times.
And about 2 days ago I noticed that the design had changed.
But only today was I able to try to restore it.

.zshrc from VirtualBox Manajro (I copied it from there and now use it.)

# Use powerline
# Has weird character width
# Example:
#    is not a diamond
# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt

~/.p10k.zsh — There is no such file either in the virtual machine or in mine

If you just want to start over with the default Manjaro ZSH config:

First backup your p10k.zsh & .zshrc:

mv ~/.p10k.zsh ~/.p10k.zsh.bak
mv ~/.zshrc ~/.zshrc.bak

Then copy in the defaults:

cp /usr/share/zsh/p10k.zsh ~/.p10k.zsh
cp /etc/skel/.zshrc ~/.zshrc

has no effect…

Thank you for your help. I’ll get used to this view. The main thing is that we managed to restore the ability to use history.

You’ll need to source the updated files:

source ~/.zshrc ~/.p10k.zsh

You may also need to restart ZSH:

exec zsh

Also make sure you’re using the default Manjaro profile in Konsole.

1 Like

I don’t understand you about this.

«Also make sure you’re using the default Manjaro profile in Konsole.»

How to find out?

I restart the program every time Konsole

Type the commands in a terminal.

In Konsole: Menu > Settings > Configure Konsole > Profiles, choose the default.

response is empty
I tried using a restore point from TimeShift before the update. But as it turned out, the view was spoiled even before the update. Although I didn’t do anything specifically that could affect the appearance of ZSH

Yes, that’s expected.

Are you sure? No one else reported an issue.


I went to bed. Very grateful for your time!

This is how you quote someone else: :wink:


1 Like