Zsh Konsole special characters

I have manjaro-zsh-config installed (which also installs nerd-fonts-noto-sans-mono) and run fc-cache -fv and copied /etc/skel/.zshrc to ~/.zshrc then run source ~/.zshrc and set font to Noto Sans Mono in profile settings, but I still get characters like squares in Konsole

Screenshot_20220817_100206

Hello,

Try another font maybe Fira Code or whatever other font that has glyphs

Even Fira Code shows the same problem.

Read through this Zsh powerline symbols don't appear in Konsole
Maybe it will help… also this How do you enable symbol graphics in Konsole?

I tried all attemps, nothing worked.

Well, why do you think nerd fonts got installed? Either use that or what they recommend on powerlevel10k github page, which is, I think, ttf-meslo-nerd-font-powerlevel10k.

1 Like

I thought that nerd-fonts-noto-sans-mono simply patches the same Noto Sans Mono font family, but it add another font called NotoSansMono Nerd at the end of the list. Thanks :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.