Zsh: command not found: aiStarter

Hi friends!!! Iḿ triyng to set up app inventor on my Manjaro (updated) environment (Gnome), then, following installation steps:

which aiStarter 

But when i try to execute aiStarter on terminal:

zsh: command not found: aiStarter

Any idea?

The shell will only execute applications that can be found in one of the directories of the $PATH. Either you must add /usr/google/appinventor/commands-for-Appinventor to your $PATH or type the full path to the executable on the command line, like so… :arrow_down:


Also make sure that the file has execute permission, and that it was intended to be launched by itself, and not as a subcommand of another utility — I’m not familiar with that software, so I don’t know.

Hi Aragorn!!! Thanks by your quick answer…

you must add /usr/google/appinventor/commands-for-Appinventor to your $PATH

I did that,this way:

Go to your ~/.bashrc or ~/.bash_profile and add these lines:


But zsh still saying:

zsh: command not found: aiStarter

You use zsh, so you should add this to ~/.zshrc


Only in .zshrc? Cause i did that too…but when i run:

source .zshrc

i get this:

What is the output of…

ls -l /usr/google/appinventor/commands-for-Appinventor


Note: Please don’t include screenshots. Copy the shell output with the mouse, use the </> button in the toolbar of the post editor and paste the output between the lines with the backticks.


ls -l /usr/google/appinventor/commands-for-Appinventor

total 23308
-rwxr-xr-x 1 root root 1318951 feb 11 10:20 adb
-rwxr-xr-x 1 root root      44 feb 11 10:20 adbdevices
-rwxr-xr-x 1 root root      68 feb 11 10:20 adbrestart
-rwxr-xr-x 1 root root 5321452 feb 11 10:20 aiStarter
-rwxr-xr-x 1 root root   33428 feb 11 10:20 emulator
-rwxr-xr-x 1 root root 2854417 feb 11 10:20 emulator64-arm
-rwxr-xr-x 1 root root 2884527 feb 11 10:20 emulator64-mips
-rwxr-xr-x 1 root root 2956240 feb 11 10:20 emulator64-x86
-rwxr-xr-x 1 root root 2706541 feb 11 10:20 emulator-arm
-rwxr-xr-x 1 root root 2679855 feb 11 10:20 emulator-mips
-rwxr-xr-x 1 root root 2811534 feb 11 10:20 emulator-x86
-rwxr-xr-x 1 root root  215626 feb 11 10:20 fastboot
-rwxr-xr-x 1 root root     117 feb 11 10:20 getversion
-rwxr-xr-x 1 root root     175 feb 11 10:20 kill-emulator
-rwxr-xr-x 1 root root   12191 feb 11 10:20 mksdcard
-rwxr-xr-x 1 root root     972 feb 11 10:20 reset-emulator
-rwxr-xr-x 1 root root    1510 feb 11 10:20 run-emulator
-rwxr-xr-x 1 root root     146 feb 11 10:20 unlock-emulator-keyboard

What is the output of…

LC_ALL=C /usr/google/appinventor/commands-for-Appinventor/aiStarter


LC_ALL=C /usr/google/appinventor/commands-for-Appinventor/aiStarter

zsh: no such file or directory: /usr/google/appinventor/commands-for-Appinventor/aiStarter

This suggests that the name aiStarter may contain hidden characters. :thinking:

mv aiStarter aiStarter           ✔ 
mv: 'aiStarter' y 'aiStarter' son el mismo fichero

That says “aiStarter” and “aiStarter” are the same file

Have you tried running it as bash aiStarter from the folder?

I did: ./aiStarter but i get:

zsh: no existe el fichero o el directorio: ./aiStarter

That’s not what I said. I said to run it via bash, not zsh.

Zsh does things a little different compared to bash and some other shells.

I did it rigth now, and i get:

bash aiStarter                             
aiStarter: aiStarter: no se puede ejecutar el fichero binario


Binary file can not be executed

Okay, matbe it’s bash ./aiStarter

Then??? Permission issues on aiStarter file???

No, it has the right permissions — your ls -l output showed that.

What is the output of… :arrow_down:

LC_ALL=C file /usr/google/appinventor/commands-for-Appinventor/aiStarter


Hint: Please type LC_ALL=C before every command you are trying to execute in the shell and of which you need to paste the output here. Not everyone here understands Spanish. :wink:

The setup programs are 32-bit software. If you have a 64-bit system you may need to install libraries the let your machine run 32-bit software. One way to do this is to run the command sudo apt-get install lib32z1 , but this might not work on all GNU/Linux distributions, and you may need to do some investigation for your particular system.

1 Like


/usr/google/appinventor/commands-for-Appinventor/aiStarter: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.18, BuildID[sha1]=0b7ec69824a1ff621c8e697a32d12f1cf42274c6, with debug_info, not stripped