Znikły katalogi - Manjaro zresetowało się. Co robić

#1

Witam,
mam bardzo dziwną sytuację wczoraj w czasie pracy na Manjaro KDE zobaczyłem dziwny komunikat, że Mega nie może zsynchronizować katalogów typu home/user/Documents bo... nie istnieje!

Wcześniej w czasie uruchamiania komputera pojawiał się komunikat o błędzie, że Manjaro nie ma dostępu do katalogu /home/user ale później wszystko chodziło ok.

Samo Manjaro zresetowało się do domyślnego wyglądu. Programy wcześniej zainstalowane są, ale nie ma ich ustawień.

Wczoraj, kiedy pojawiły się problemy widziałem, że komputer chodził bardzo intensywnie a procesem który był dominujący było baloo. Zdecydowałem się zabić ten proces. Teraz zastanawiam się czy nie to było przyczyną utraty katalogów. Dane de facto są na dysku, tyle, że nie mogę się do nich dostać: Dolphin pokazuje katalogu, ale daje komunikat: Katalog nie istnieje.

Zastanawiam się czy to jest błąd Manjaro czy raczej problem z twardym dyskiem. Mam Della E5430, którego używam ok. 6 lat.

Co robić? Jak odzyskać ustawienia i dane?

Pozdrawiam,
Dario

#2

Nie wydaje mi się, że to ma coś wspólnego z Balooo. Raczej Baloo miał problem bo dysk zaczynał padać...
Poszukaj w sieci, są programy, które ładujesz na USB, ustawiasz bootowanie na USB i wtedy dostajesz program do testów dysku twardego, np. czy są jakieś uszkodzone sekcje itd.

O, znalazłem filmik, który mi pomógł, ale to było baaaardzo dawno temu, więc pewnie są nowsze aplikacje, ale sprawdź sobie to:

Dolphin widzi katalogi, bo ma zapis, że tam powinien być, ale jak próbuje otworzyć to napotyka problem. Wygląda to na problem z partycją lub częścią dysku, na którym jest ta partycja.

Co do danych, to jeśli synchronizowałeś cały folder usera z megasync, to tam twoje dane dalej są, zaloguj się na stronę i będziesz miał do nich dostęp.

Polecam robienie backupów /home na zewnętrznym dysku.

Na szczęście dysk czy partycja nie padły totalnie bo system by w ogóle nie zabootował. Fakt, że się zalogujesz jako użytkownik i system oraz programy odtworzyły sobie domyślne configi, świadczy że jest dostęp do partycji i folderu użytkownika, tylko nie ma dostępu do danych, które wcześniej były zapisane.

Sytuacja wygląda poważnie, więc na tą chwilę musisz sprawdzić stan dysku i możliwe, że trzeba będzie go wymienić, zainstalować system ponownie i odtworzyć dane z chmury.
Możesz też próbować działać na części dysku, która działa, ale jeśli masz bad sectors, to uszkodzenia będą się rozchodzić.
Mam stary komputer PC, który używa mój tata. Partycja w Windows 7 jest tam dosłownie zharatana bad sektorami (program znalazł ich chyba z parędziesiąt), więc postawiłem Linuxa na innej partycji, która nie miała uszkodzeń i mimo bad sektorów pozostała partycja działa, więc opiłki nie przeniosły się na nią póki co, ale partycja Windowsowa jeszcze jakiś czas się uruchamiała, ale w końcu się posypała zupełnie, więc widać, że uszkodzenie dysku postępuje.

Nie jestem ekspertem w temacie, więc poszukaj programy do badania stanu dysku, partycji, itp, może da się coś zrobić, żeby dostać się do danych.

EDYCJA: Aha, jaki system plików masz? Ext4?

#3

Witaj,
Najpierw wielkie dzieki za szybką odpowiedz! Potwierdzasz moje intuicje. Też myślę, że Baloo szalało bo coś złego działo się na dysku. Na szczęście cały backup ma na Mega wiec nie martwie się o dokumenty. Mam ext4. Spróbuję powalczyć z badaniem dysku. Zobaczymy czy coś wyjdzie. Ale pewnie skończy się na wymianie dysku lub kupnie nowego laptopa, bo ten rzeczywiście troche się już napracował.
Pozdrawiam i radosnych Świąt!

#4

Dzięki i również życzę Wesołych Świąt :slight_smile: