Zeitsynchronisierung funktioniert nicht (mehr)

Hallo,
ich musste gestern feststellen, das die automatische Synchronisation der Systemzeit bei meinem Notebook nicht (mehr) funktioniert.

Wenn ich timedatectl aufrufe, bekomme ich folgendes angezeigt:

$ timedatectl
Local time: Mi 2019-04-03 16:39:17 CEST
Universal time: Mi 2019-04-03 14:39:17 UTC
RTC time: Mi 2019-04-03 16:39:17
Time zone: Europe/Berlin (CEST, +0200)
System clock synchronized: no
NTP service: inactive
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.

Als Status von systemd-timesyncd wird folgendes angezeigt:

$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; >
Active: failed (Result: exit-code) since Wed 2019-04-03 17:15:59 CEST; 5s ago
Docs: man:systemd-timesyncd.service(8)
Process: 15274 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, sta>
Main PID: 15274 (code=exited, status=238/STATE_DIRECTORY)

Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Service has>
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Scheduled r>
Apr 03 17:15:59 Ostfriesland systemd[1]: Stopped Network Time Synchronization.
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Start reque>
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Failed with>
Apr 03 17:15:59 Ostfriesland systemd[1]: Failed to start Network Time Synchroni>
lines 1-13/13 (END)…skipping…
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2019-04-03 17:15:59 CEST; 5s ago
Docs: man:systemd-timesyncd.service(8)
Process: 15274 ExecStart=/usr/lib/systemd/systemd-timesyncd (code=exited, status=238/STATE_DIRECTORY)
Main PID: 15274 (code=exited, status=238/STATE_DIRECTORY)

Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Service has no hold-off time (RestartSec=0), scheduling restart.
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Scheduled restart job, restart counter is at 5.
Apr 03 17:15:59 Ostfriesland systemd[1]: Stopped Network Time Synchronization.
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Start request repeated too quickly.
Apr 03 17:15:59 Ostfriesland systemd[1]: systemd-timesyncd.service: Failed with result ‘exit-code’.
Apr 03 17:15:59 Ostfriesland systemd[1]: Failed to start Network Time Synchronization.

Hat jemand eine Idee, wie sich das Problem lösen lässt?

Hallo OstfrieseInFran,

öffne einen Terminal und gib

manjaro-settings-manager

ein.

Danach auf “Zeit und Datum” klicken.
Zum Schluß einen Haken bei
“Setze Datum und Uhrzeit automatisch”
setzen.

Ein Dual-Boot User.

Schau mal ins journal, deine status Posts sind leider etwas abgeschnitten. Vielleicht gibt es einen Grund warum es nicht geklappt hat.

journalctl --no-pager -b -u systemd-timesyncd.service

Bringt nichts. Beim nächsten Öffnen ist der Haken wieder weg.

Ein Dual-Boot User.

Eigentlich nicht.

journalctl --no-pager -b -u systemd-timesyncd.service

Guckst Du: https://pastebin.com/LJT1Ear4

Linux erwartet die Hardware Uhr normalerweise in UTC. Nur Windows stellt die RTC Uhr auf die Lokale Uhrzeit. Beim Dual-Boot führt das oft zu Problemen. Die Warnung von timedatectl solltest du vielleicht beachten.

Failed to set up special execution directory in /var/lib: Not a directory
Failed at step STATE_DIRECTORY spawning /usr/lib/systemd/systemd-timesyncd: Not a directory

Das ist wohl das Hauptproblem.

Was ist die Ausgabe von

ls -lad /var/lib/private

Oder hilft das?

Okay, dank

hab ich die Ursache gefunden. Das Verzeichnis

/var/lib/systemd/timesync

war aus welchen Gründen auch immer ein Symlink auf

../private/systemd/timesync

Symlink gelöscht und danach lies sich auch systemd-timesync ohne Probleme starten.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark