Youtube videos are lagging while connected to Bluetooth speaker

hey guys I am facing terrible errors in manajro xfce

bluetooth connectivity is very poor
I am not able to connect to my bluetooth speaker very easily
i have to try it more than 10 times to connect my bluetooth speaker to manjaro xfce
if it gets connected the bluetooth all of a sudden gets deactivated and gets switched off
then again I have to try to connect it by turning on the bluetooth in system
after my speaker gets connected to manjaro the youtube videos starts lagging
even in half screen on 720p videos are lagging
but after disconnecting the speaker and then playing the video the videos doesn’t lag then

i have faced many temporary bluetooth errors in manjaro xfce previously
a restart was fine for them
but this time it’s just terrible and frustrating

here is my system info

[ayushk@ayush-inspiron3541 ~]$ inxi -F 
  Host: ayush-inspiron3541 Kernel: 5.10.56-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 3541 v: N/A 
  serial: <superuser required> 
  Mobo: Dell model: Inspiron 3541 v: A07 serial: <superuser required> 
  BIOS: Dell v: A07 date: 11/27/2015 
  Info: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP cache: L2: 2 MiB 
  Speed: 998 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 998 
  3: 998 4: 998 
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.13 driver: loaded: ati,radeon 
  unloaded: modesetting resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.10.56-1-MANJARO LLVM 12.0.1) 
  v: 4.5 Mesa 21.1.6 
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel 
  Device-2: AMD FCH Azalia driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.56-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Sound Server-3: PipeWire v: 0.3.33 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  IF: enp2s0 state: down mac: 20:47:47:53:db:2d 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp3s0 state: up mac: b0:c0:90:62:24:ff 
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 
  Local Storage: total: 465.76 GiB used: 41.82 GiB (9.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  ID-1: / size: 450.28 GiB used: 41.77 GiB (9.3%) fs: ext4 dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 7.21 GiB used: 44.5 MiB (0.6%) 
  dev: /dev/sda2 
  System Temperatures: cpu: 61.0 C mobo: 55.0 C gpu: radeon temp: 61.0 C 
  Fan Speeds (RPM): cpu: 4780 
  Processes: 200 Uptime: 2h 2m Memory: 3.28 GiB used: 2.26 GiB (69.1%) 
  Shell: Bash inxi: 3.3.06 
[ayushk@ayush-inspiron3541 ~]$ 

make sure your using a 5ghz wifi when using bluetooth, bluetooth uses 2.4ghz frequency which can interfere, slowing things down.

Tip: When using HTML tags for preformatted text, use <pre><code> instead of <pre>:


Please edit your post accordingly.

System has 2 active sound servers

Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.33 running: yes

Pipewire might be trying to take control of audio devices from PulseAudio, but Pipewire cannot work unless all PulseAudio packages are replaced with Pipewire dependencies

You can disable the pipewire systemd socket and service to continue using PulseAudio

systemctl --user mask --now pipewire.socket && systemctl --user stop pipewire.service

Or Install manjaro-pipewire to get the additional dependency files for Pipewire and remove PulseAudio

i used this code
but I think nothing happened


how can I do that