Youtube playback Rock Pi 4b Plus

I just got manjaro installed to the emmc with manjaro-arm-installer and youtube playback does not work in Firefox or Chromium.

For Chromium, at first it was using software renderer for video decoding. I changed this to hardware decoding but youtube still does not work.
Firefox does the same thing, but I didn’t try to see if it’s software or hardware decoding.

This seems to be a manjaro specific issue and not drivers/the board itself.

The page loads and shows a spinning circle for loading the video. I open stats for nerds and there is no network activity at all and no buffer progress on status bar. I tried changing connection from eth0 to wlan0 but it still doesn’t work.

Any ideas?

Why do you think it’s just a Manjaro thing?
Have you tried other mainline based distros?

As far as I know, hardware decoding does not work on mainline yet, as the drivers are still in staging, which means userspace (ffmpeg etc) does not want to support it yet. Software decoding should work though.

I haven’t personally tested it but have seen it use software decoding from other people on youtube. I don’t think they were on mainline, but I’m not sure it should make a difference.

And yeah software rendering should work, that’s why I’m thinking this is manjaro specific. Maybe the manjaro-arm-installer isn’t installing some codecs needed or something?

Firefox had hardware encoding enabled by default so I disabled it and still the same thing. the videos won’t load.

Tested Vimeo with Chromium with hardware accelerated video decoding and it’s flawless. I have no idea where to even start troubleshooting the youtube problem.

I figured it out. There some kind of issue with the way manjaro-arm-installer sets up the time/timezone. After correcting it youtube playback works fine.

Whaty issue would that be?
It sets the timezone to what you selected in the dialog.
It doesn’t set NTP though. We should probably do that…

Okay, now done.

i’m not too familiar with how all that works but im guessing it was ntp. thanks a lot!