You are not authorized to mount this device

kde
usb
beta
mount

#1

Manjaro KDE recent RC development version.

It’s been going well for the most part, I plugged in a USB stick, accessed it and copied some files over, my panel froze and became unresponsive/didn’t update for some time, then became responsive and I got a transfer progress notification, but no transfer initiated.

I ended up stopping it and not being able to access the mounted location again, so I removed the USB stick, plugged it back in, Dolphin could not open it, and the notification pop-up would get stuck on “accessing”… did a restart, tried again, and got an error that the title of this thread states. Dolphin doesn’t list it as a device on the left.

I’m hoping that there is a way to resolve this and access my USB stick and it’s media again? It won’t show up in KDE Partition Manager either…

Other USB sticks are working fine.


inxi -Fxz
System:    Host: xiaobu-linux Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MAXSUN model: MS-HDZ H310M-666 serial: <filter> UEFI: American Megatrends v: 5.12 
           date: 04/28/2018 
CPU:       Topology: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33708 
           Speed: 1302 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 1400 2: 1400 3: 1400 4: 1400 5: 1400 6: 1400 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia v: 415.18 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 415.18 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: GEMBIRD type: USB driver: hid-generic,snd-usb-audio,usb-storage,usbhid bus ID: 1-7:3 
           Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: ASUSTek type: USB driver: mt76x2u bus ID: 2-2:2 
           IF: usb-wifi-asus state: up speed: N/A duplex: N/A mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.63 TiB used: 9.57 GiB (0.6%) 
           ID-1: /dev/sda vendor: Colorful model: SL300 120GB size: 111.79 GiB 
           ID-2: /dev/sdb type: USB model: Buildwin MediaPlayer size: 1.52 TiB 
Partition: ID-1: / size: 19.99 GiB used: 7.66 GiB (38.3%) fs: xfs dev: /dev/sda5 
           ID-2: /home size: 19.99 GiB used: 1.83 GiB (9.2%) fs: xfs dev: /dev/sda6 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 30.0 C mobo: N/A gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 234 Uptime: 8m Memory: 15.62 GiB used: 1.54 GiB (9.9%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 4.4.23 inxi: 3.0.27

Correction, it shows up on Dolphin, it was only after that notification error about failing to mount it that it disappeared. I plugged it in again and ran the following:

sudo fdisk -l
Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Disk model: Colorful SL300 1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1A9F83B0-91AB-414F-9493-B97007BB3E76

Device         Start       End  Sectors  Size Type
/dev/sda1       2048   1023999  1021952  499M Windows recovery environment
/dev/sda2    1024000   1228799   204800  100M EFI System
/dev/sda3    1228800   1261567    32768   16M Microsoft reserved
/dev/sda4    1261568  83888127 82626560 39.4G Microsoft basic data
/dev/sda5   83888128 125831167 41943040   20G Linux filesystem
/dev/sda6  125831168 167774207 41943040   20G Linux filesystem
/dev/sda7  167774208 176162815  8388608    4G Linux swap
/dev/sda8  176162816 218105855 41943040   20G Linux filesystem


Disk /dev/sdb: 1.5 TiB, 1672431203840 bytes, 3266467195 sectors
Disk model:  MediaPlayer    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sdc: 57.6 GiB, 61872793600 bytes, 120845300 sectors
Disk model: DataTraveler 3.0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 671BF396-40E7-4CDD-BF33-FBFD5AAF3B44

Device     Start       End   Sectors  Size Type
/dev/sdc1   2048 120845266 120843219 57.6G Microsoft basic data

Mounting via Dolphin gives the following error message in a red box above the fileview:

An error occurred while accessing ‘CCCOMA_X64F’, the system responded: An unspecified error has occurred: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Used KDE Partition Manager and the USB stick showed up too, right clicked /sdc1 and chose check, this is the output:

Check and repair partition ‘/dev/sdc1’ (57.62 GiB, exfat) 
Job: Check file system on partition ‘/dev/sdc1’ 
Command: exfatfsck /dev/sdc1 
exfatfsck 1.3.0
Checking file system on /dev/sdc1.
WARN: volume was not unmounted cleanly.
ERROR: fsync failed: Input/output error.
File system checking stopped. ERRORS FOUND: 1, FIXED: 0. 

Command: exfatfsck /dev/sdc1 
exfatfsck 1.3.0
Checking file system on /dev/sdc1.
ERROR: failed to open '/dev/sdc1' in read-write mode: No such file or directory.
File system checking stopped. ERRORS FOUND: 1, FIXED: 0. 
Check file system on partition ‘/dev/sdc1’: Error
Check and repair partition ‘/dev/sdc1’ (57.62 GiB, exfat): Error

So problem is the unclean mount? Any idea how to fix it?


#2

Apparently you can’t fix the issue for exFAT on Linux, I came across the suggestion here that stated I need to use Windows to fix it due to being proprietary FS? Luckily I had Windows on hand and that worked a charm… still it’d be good to know if it were possible to fix in Linux, the KDE Partition Manager check command just seemed to run sudo fsck /dev/sdc1 which delegated to some exfat utility with same output as provided from KDE Partition Manager.