Yakuake background - transparency works, blur doesn't

I’ve set 30% transparency and blurring in my terminal profile which is picked up fine by the Konsole. However, Yakuake only appears to be able to do the transparency element and not the background blurring. Anyone else noticed this and been able to fix it? If so how?

Note, the system has been restarted. I tried closing and opening Yakuake first. Neither made any diffference. It is clearly able to read the profile though.

1 Like

It is a known “bug”, hopefully it will be resolved in the not so distant future.
https://phabricator.kde.org/D10063

Meanwhile, you could add this script to your .bashrc / .zshrc to regain the blur in yakuake:

if [[ $(ps --no-header -p $PPID -o comm | grep -Ev '^(yakuake|konsole)$' ) ]]; then
        for wid in $(xdotool search --pid $PPID); do
            xprop -f _KDE_NET_WM_BLUR_BEHIND_REGION 32c -set _KDE_NET_WM_BLUR_BEHIND_REGION 0 -id $wid; done
fi

Note that it needs xdotool installed. You can also remove the “|konsole” part since most likely you already use it’s native blur.

Source: https://www.reddit.com/r/kde/comments/6jzuwu/konsole_and_yakuake_blur/

3 Likes

thanks for the information, the fix doesn’t take though with the current build of Plasma. I tried all three versions in that reddit thread. I have compositing enabled so may well have to go down the route of using Kvantum instead.

Are you sure you pasted the script correctly in your .xxxrc?

I can assure you that at least the .zshrc version works currently in my setup, compositing enabled and all:

This is copied straight from my .zshrc:

#blur for  yakuake
if [[ $(ps --no-header -p $PPID -o comm) =~ '^yakuake$' ]]; then
        for wid in $(xdotool search --pid $PPID); do
            xprop -f _KDE_NET_WM_BLUR_BEHIND_REGION 32c -set _KDE_NET_WM_BLUR_BEHIND_REGION 0 -id $wid; done
fi

Thanks again, I have now got it working with the following in .bashrc. I don’t have .zshrc.

regarding pasting, I was pasting into the file directly using nano but the quotation marks had to go to make it work. I don’t use GUI editors since the encoding can be messed up sometimes.

if [[ $(ps --no-header -p $PPID -o comm) =~ ^yakuake$ ]]; then
        for wid in $(xdotool search --pid $PPID); do
            xprop -f _KDE_NET_WM_BLUR_BEHIND_REGION 32c -set _KDE_NET_WM_BLUR_BEHIND_REGION 0 -id $wid; done
fi

mari3 comment from the reddit thread a bit further down:

For bash you can borrow my improved version, just remove the quotation marks around the term so it is just: [[ foo =~ ^yakuake|konsole$ ]]

You’re welcome :slight_smile:

I guess, regardless the final script, @Signalrunner deserves the credit :wink:

1 Like

Hahaha, thank you buddy! But all the credit should go to the person who created the script in the first place, I’m just the messenger.

Besides, I couldn’t care less about it, I’m just glad whenever I can help a fellow “manjarian”. Manjarian? Manjaroo? Manjurian candidate? You know what I mean :wink:

1 Like

yeah I thought so too and marked @Signalrunner’s post as the solution, he changed the solution to mine.

anyhow, the manjaro solution(s) are there for anyone else who needs them which is the main thing. It seems to vary by distribution and desktop

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by