Yad lost it's tool tip after recent system upgrade in XFCE

Hi all,
I have a script that creates a yad notification with text option. It has worked fine for over a year. Recently the tool tip (i.e. text option) stopped appearing - probably after some update or another. I call it like this:
$yad --notification --text="this is a test"
Normally, an icon shows up in the tray and mousing over it causes a balloon to appear with the text in it. Now the icon appears, but no balloon with text.
I am using XFCE, and yad --version yields 7.3 (GTK+ 3.24.24).
Any help diagnosing or fixing would be helpful. I can supply versions of various packages if needed, but basically I am fully up to date with the latest Manjaro.


Issuing a

yad --nofification --text="test"

Gives me a test tube with a green liquid in it - If I click the icon it disappear - hovering shows a tool tip with the text inside. (polybar tray)

Besides a minor gtk diff (mine is 3.24.25) there is no differences

➜  ~ yad --version                   
7.3 (GTK+ 3.24.25)

Some more data points:

  1. Tried on another laptop I have with up-to-date Manjaro on it, but LXQt desktop environment. Still no tooltip. Tried downgrading yad to 4.1-2. Still no tootip.
    Conclusions: (a) XFCE is probably not the problem. (b) It’s nothing new in yad, but probably something new about the system that yad is no longer compatible with.
  2. Just for grins I tried it on a VirtualMachine with straight Archlinux and Deepin DE, last updated on 12-20-2020. No tooltip there either.
    What’s going on???