Xte/xdotool Super button doesn't work on Gnome 40

After update [Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac:

After switching to gnome 40, I have an issue with mouse side buttons.
I was using xbindkeys with xte to bind a mouse button to ‘Show the activities overview’ with Super+R (previously set this as keyboard shortcut)

The command that used to work was
xte 'keydown Super_L' 'key R' 'keyup Super_L'

The strange thing is that in Telegram it just types ‘r’, in browser it works like ‘back’ and ‘forward’ (which is by default), in other apps it does nothing. Gnome shortcut Super+R still works fine.

Problem comes with xte and xdotool - with new gnome they stopped simulating ‘Super’ button

I’ve been testing xbindkeys with xte and xdotool - both work fine with bindings:

"xdotool key Control+n"
   release + b:8


"xte 'keydown Control_L' 'key n' 'keyup Control_L'"
   release + b:8

both open new window in Firefox, so combination Ctrl+n works fine.

The issue comes with ‘Super’ button, which stopped working since Gnome 40.
I’ve tried in xte both ‘Super_L’ and ‘Meta_L’ and none of them function. Neither works xdotool with ‘key super’.

those only work if your running xorg/x11, default for gnome 40 is wayland.
logout select user, click icon bottom right corner.

1 Like

Thanks for pointing it out!

Switching to Xorg brings everything back to normal.

But I went further and found a great alternative for xbindkeys on Wayland - sezanzeb/key-mapper (there’s a build in AUR from creator of this package)

Everything works, except switching keyboard locale ALT_L+SHIFT_L doesn’t work at all, but SHIFT_L+ALT_L does the trick.

Problem solved!

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

After reading the difference between Xorg and Wayland, the thing that keeps bothering me is why did xbindkeys work both with xte and xdotool ? I mean I could bind almost everything except ‘Super’ key.

Doesn’t it that on Wayland apps work with full isolation and none of xbindkeys, xte, xdotool can ever know what keys I’m pressing on my mouse/keyboard while using other apps?

I mean I could replicate ‘Ctrl+n’ and use it on Firefox with both xbindkeys+xte and xbindkeys+xdotool.

Should it work at all on Wayland or it is a bug?

Please read this:

then file a RFI upstream…


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.