Xserver not starting on boot

I was able to switch. I had a folder named mhwd.d but xinit wanst present so i created it.
I have added the kernel parameter yet xbacklight inst working with NVIDIA. It works fine with Intel though

sudo nano /etc/switch/nvidia/nvidia-xorg.conf
add this brightness control line
Option "RegistryDwords" "EnableBrightnessControl=1"

looks like this:

#/etc/switch/nvidia/99-nvidia.conf
#adjust BusID to match your nvidia GPU
#uncomment and edit the DPI option as needed
#to fix scaling issues.


Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver  "nvidia"
    BusID   "PCI:1:0:0"
    #Option  "DPI" "96 x 96"    #adjust this value as needed to fix scaling
    Option  "AllowEmptyInitialConfiguration"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Section "Extensions"
    Option  "Composite" "Enable"
EndSection

save/exit
sudo set-nvidia.sh
and reboot

Hi @dglt ,
I have added the line to the file but Im still not getting brightness control in Nvidia mode

check the arch wiki on backlight, i dont think you can use xbacklight on the nvidia gpu, i wanna say acpi_backlight but im not certain and i dont have the time ATM to go hunting. a little research should take care of the issue.

Sure, ill have a look
Thanks for the help.

Hi @dglt
Arch wiki says:
If you get the "No outputs have backlight property" error, it is because xrandr/xbacklight does not choose the right directory in /sys/class/backlight . You can specify the directory by setting the Backlight option of the device section in xorg.conf . For instance, if the name of the directory is intel_backlight , the device section can be configured as follows:

/etc/X11/xorg.conf
-------------------
Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
EndSection

I dont have a xorg.conf
is something messy here?

because we use /etc/X11/xorg.conf.d/*.conf for xorg configurations, you can try adding that but it may or may not cause issues with nvidia mode. alternatively you could try replacing the nvidia backlight line you added with just this line

Option      "Backlight"  "intel_backlight"

Thanks
No luck thought!
Apparently light works just fine but i wanted xbacklight for polybar

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark