Xrdp and polkit

I installed xrdp and xorg onto my Xfce install to access my server remotely with a full GUI. I created the file /etc/X11/Xwrapper.config with the single line allowed_users=anybody.

I was having issues creating a sessions and modified the ~/.xinitrc file based on a post I found:

#exec $(get_session “$1”)
exec dbus-launch --sh-syntax --exit-with-session xfce4-session

Everything is working fine except when I go to update using the Pamac GUI, I get a popup of “Authorization Failed” without it ever asking me for a password. Pacman works fine from the terminal. Pamac works fine when I log into the local session as well.

I found this topic on an Ubuntu forum, but the folder/file structure seems to be different in Manjaro Xfce. Apparently I can’t include links in my post, but if you google “How can I give permission to a user be able to UNLOCK Users GUI to Create New Users when connected thru xRDP Sessions?” you should see it at askubuntu.

Is there any way to get polkit to give full permissions to a remote session through xrdp?

Thanks in advance.

Please read this:

(And that’s the best I can do for you as I’m on KDE and don’t use xdrp nor polkit)


That is polkit not running. Add a command to your xinitrc (before the exec command) to ensure the polkit daemon is launched. Depending on the polkit agent available on Xfce (not an xfce myself) but my guess is gnome-polkit

gnome-polkit &

Another dead easy way of getting the functionality you look for is to use TigerVNC over ssh.

I did a writeup on it some time ago.

1 Like


gnome-polkit &

did not seem to do it. I checked the task manager and polkit-gnome-authentication-agent-1 is running with or without that command in xinitrc.

I was looking to remote in via Windows remote desktop connection, but I’ll take a look into setting up TigerVNC.