Xrandr do not show HDMI

Hello everyone,

I have an issue with my ThinkPad. I wanted to plug a second screen via HDMI (quite modern iiyama)

But No Signal Detected

my xrandr :

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     60.03*+  59.93    47.99  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I only have eDP1 and VIRTUAL1 no HDMI ??? :confused:

I tried with arandr it’s the same…

I’m a little bit confused… is it related to my Nvidia card ?

From the output you’ve provided, we cannot determine whether or not you’ve got an nVidia driver installed or not, so an:

inxi --full --verbosity=7 --filter --no-host

would be beneficial…

Humm… right it’s displaying N/A

Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8c 
           Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus ID: 1-8:3 chip ID: 5986:2115 
           Display: x11 server: X.Org 1.20.8 driver: intel resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.5 direct render: Yes

So you do not have an nVidia driver installed and as the HDMI port is driven by the nVidia only, you need to install one.

However, as you need both the Intel (for the DVI) and the nVidia driver (for the HDMI port), I’m not going to give you a solution as I’m running on nVidia only and will let someone with a dual nVidia - Intel give you a better response than I could give @bogdancovaciu

:innocent:

okay thanks, I will search about that

The base command to install the prime driver for both I know and that is:

sudo mhwd --install pci  video-hybrid-intel-nvidia-440xx-prime 

but as I said, I don’t have your kind of hardware so I’m not an expert on this bit…

:sob:

$ sudo mhwd --install pci  video-hybrid-intel-nvidia-440xx-prime 
Error: config 'video-hybrid-intel-nvidia-440xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-430xx-bumblebee
  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd --remove pci video-hybrid-intel-nvidia-430xx-bumblebee
    sudo mhwd --install pci  video-hybrid-intel-nvidia-440xx-prime
    sudo reboot
    
  • run the application you want to run on HDMI with:

    prime-run appname
    

for more info look here as I know it exists, but have never used it…

(sorry for the late reply: I hit the maximum post level yesterday and had to wait 24h to post again)

1 Like

Hey, I used this to configure the NVIDIA and Intel card

sudo mhwd -a pci nonfree 0300

Mor info can be found here in case you don’t want the nonfree drivers.
https://wiki.manjaro.org/Configure_Graphics_Cards

This has not solved the issue of not detecting the HDMI tho…

This is the solution I’m analyzing btw.

https://wiki.manjaro.org/index.php?title=Optimus_Manager

2 Likes

Still having the problem? If yes: the easy solution is to run pure nVidia as I dug into the ThinkPad problem for another user and the HDMI port is only driven by the nVidia card, so the easy solution is to drop hybrid drivers and go to nVidia only and then everything works as expected!

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd --listinstalled
    sudo mhwd --remove pci EverySingleLineOfOutputAbove
    sudo mhwd --remove pci OneLinePerDriverInbstalled
    sudo mhwd --install pci video-nvidia-YYYxx
    

where YYY is 440 if you do need CUDA and 450 if you don’t (at the time of this writing the 450 driver has “issues” with CUDA…

i’ve been running like this for the last 3 years and haven’t noticed any difference in heat or battery…

:innocent:

Hi !

Sorry long time, I had to use my laptop for work stuff, I tried you’re solution, but it fails…

Probably because bumblebee leave some config files somewhere…

I ended up with [FAILED] Failed to start Light Display Manager which was very scary.

I switch to SDDM and restore bumblebee :frowning: I think a should search a solution with bumblebee anyway

– I was so scared :confused:

1 Like

Don’t be. The TTY is always there for you. Or SSH.

PRIME render offload is an officially supported method that performs better than bumblebee. I simply see no reason to use bumblebee.

Some (older) cards are not supported by the prime drivers so a minority of people are still forced to use Bumblebee… :wink:

In this case it isn’t as the GeForce GTX 1050 is supported by the prime drivers…

I know it is a bit old topic but I have the same problem and the topic does not have a conclusion here yet. Bumblebee driver does not detect HDMI. The Nvidia Prime driver detects my external monitor on HDMI (though not always, more often it does not detect), but the issue is that with Prime the xorg process utilizes the CPU ~40% when idling (my CPU is the 6-core i7-8750H, laptop Acer A717-72G) and CPU temperature is ~50C, whereas with bumblebee it is ~38C. There are several forum topics around the internet about the high CPU usage of xorg but not some final solutions too. So, anybody has some suggestion how to get a dual display on optimus laptop with bumblebee video-hybrid-intel-nvidia-XXXxx-bumblebee driver?

Start a new topic and provide more info there as it’s hardware-specific whether to use bumblebee or prime…

:sob:

Hello guys, finally I rigged a working xrandr for external monitor ! (new lockdown force me up to retry this stuff) – some black magic there.

I’m not sure of the correct order of steps, but it might help someone

Context: I have a ThinkPad laptop, with Manjarro, and bumbleswitch which didn’t work, using SDDM DM

I removed some old nvidia drivers with mhwd
Installed fresh nonfree pci with mhwd sudo mhwd -a pci nonfree 0300

I got

video-hybrid-intel-nvidia-prime   2020.11.30  false  PCI
video-linux                    2018.05.04  true      PCI
video-modesetting             2020.01.13   true      PCI

Reboot
nvidia-smi now worked
sudo nvidia-settings still wasn’t working (wierd : ERROR: Unable to load info from any available system)

removed old /etc/modprobe.d
for me sudo rm /etc/modprobe.d/mhwd-bbswitch.conf /etc/modprobe.d/mhwd-nvidia.conf /etc/modprobe.d/mhwd-gpu.conf
blacklist unwanted stuff : sudo vim /etc/modprobe.d/nvidia.con with:

blacklist nouveau
blacklist nvidiafb
blacklist rivafb

Installed fresh optimus manager
pamac install optimus-manager && systemctl enable optimus-manager.service

Add this:

#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

to all of the following files:

/usr/local/bin/optimus.sh  
/usr/share/sddm/scripts/Xsetup

And don’t forget to chmod +x them if they wouldn’t have the Executable flag.

I had bumblebleed service still going so I disabled it + reboot
sudo systemctl disable bumblebeed.service

optimus-manager --switch nvidia
(Followed steps)

Plugged HMDI and it worked, then it’s just xrandr manipulation to make clean dual screen…

2 Likes

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.