XPS 15 9560 boot with kernel 5.10.15-1

Hey there, I’m not an expert with everything about booting manjaro on laptops, but I experienced an issue and I found a solution.

This is about my DELL XPS 15 9560 and the last update.

My setup :
Linux etienne 5.10.15-1-MANJARO #1 SMP PREEMPT Wed Feb 10 10:42:47 UTC 2021 x86_64 GNU/Linux

When I first install manjaro I didn’t had to change anything (using UEFI). But with this last update I was not able to boot at all (black screen).

The only way I found is by adding this kernel parameter :

Steps :

  • boot with a manjaro live CD
  • manjaro-chroot -a
  • nano /etc/default/grub
  • add the parameter to this line : GRUB_CMDLINE_LINUX_DEFAULT="...acpi_rev_override=1"
  • RUN update-grub

I hope this will help some of you guys.
HF <3

PS: I tried this because I remember that when I first installed manjaro (~=v17) I had to add some kernel parameters

1 Like

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into an answer to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.