XP-Pen star03 drivers and configuration

Same issue as @prab except I’ve got the XP-Pen star03.
I installed and built the xp-pen-tablet package first, rebooted, result:

[ ~]$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ PIXART USB OPTICAL MOUSE                	id=9	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N Pen               	id=10	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N Pad               	id=11	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N Mouse             	id=12	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N Keyboard          	id=13	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N Consumer Control  	id=14	[slave  pointer  (2)]
⎜   ↳ UC-Logic TABLET 1060N System Control    	id=15	[slave  pointer  (2)]
⎜   ↳ XP-PEN MOUSE                            	id=19	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=16	[slave  keyboard (3)]
    ↳ XP-PEN ERASER                           	id=17	[slave  keyboard (3)]
    ↳ XP-PEN STYLUS                           	id=18	[slave  keyboard (3)]
[ ~]$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 5543:0081 UC-Logic Technology Corp. TABLET 1060N
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 003: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 006 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[ ~]$ xsetwacom --list devices

Then I downloaded specific driver from site, installed, rebooted, used above commands - no change, i.e. nothing but one button acknowledged, which apparently has an ‘Esc’ effect.
Any more suggestions (I couldn’t quite follow @prab 's last note)?

By last note, I believe you are referring to Digimend driver and/or uclogic-prob.
When you execute the command “lsusb” the xp-pen will be listed with a specific Bus number and Device number. From your output it seems to be

Bus 004 Device 002. With that information, you can run the command “sudo uclogic-probe 4 2”. It might do the trick in your case.If not, you can try using the Digimend drivers.
Digimend drivers are available in the AUR: digimend-kernel-drivers-dkms-git
after installing, try the uclogic-probe procedure.

1 Like

Many thanks. Downloaded and installed uclogic-prob from
https://github.com/DIGImend/uclogic-tools and ran uclogic-prob 4 2 successfully, but still no tablet-recognition.
Installing digimend-kernel-drivers-dkms-git (more info here: https://aur.archlinux.org/packages/digimend-kernel-drivers-dkms-git/) shows me that core, extra, community, multilib are up to date but “error: target not found”. To that I read this: https://stackoverflow.com/questions/59288945/target-not-found-not-able-to-install-packages-in-arch-linux which leades to this: https://wiki.archlinux.org/title/Arch_User_Repository#Installing_packages - with a red warning that such packages are unofficial. And I’m not confident enough to try.
PS Also installed and ran the xp-pen-tablet star03 driver for Win 10 (on which it worked before switch to Manjaro), same result, i.e. tablet not recognised [anymore].
PPS Twice installed the driver for Win 10 from the original cd, tablet is recognised again (though not its buttons).

Hello @F2CPP

Usually a 2 weeks information becomes old in Linux world, so a year old discussion or 5 months one becomes irelevant. Moved your topic here and will try to cover a few things for you regarding tablet drivers.

AUR packages are maintained by community members/users and are not curated by official team members of Arch, but that doesn’t mean they are a bad thing to use. Just needs caution.

digimend-kernel-drivers-dkms-git AUR package is safe.
To install it you will need to install first the linux headers.
Open up terminal and run:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then build the digimend package

pamac build digimend-kernel-drivers-dkms-git

It will automatically install dkms too and set things up. Once is done you can check /usr/share/X11/xorg.conf.d/50-digimend.conf
that already has the entry for your tablet ID 5543:0081 and the driver used is wacom.

Once you reboot, the xsetwacom --list should also display your tablet.

1 Like

Thanks. Following the above referenced Arch-advice I was told pacman couldn’t find the digimend header files, which made sense in the light of your post, which did exactly that:

pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')


pamac build digimend-kernel-drivers-dkms-git

returns “no operation specified” (and pacman -S … still doesn’t install the AUR package).
With the linux header files now installed, inside the folder with PKGBUILD, I ran

makepkg -sic 

again, and following that

pacman -U digimend-kernel-drivers-dkms-git-10.r3.g4762230-1-any.pkg.tar.zst 

successfully, in /usr/share/X11/xorg.conf.d/50-digimend.conf, tablet ID and driver are shown. However, even after reboots, xsetwacom is not recognised as command.
-How is digimend-kernel-drivers-dkms-git built, as your post?

Pacman will never install AUR packages. You need an AUR helper for that.
Pamac does that.

Ok, that is a way to do it, but makes sense only if you want to change things in the PKGBUILD and then always you will take care of it, but since is using DKMS, the module for the kernel was also build?

You never mentioned that before. Is not recognized or is not listing any device? Those are not the same thing.
If is not recognized as command then you have to install xf86-input-wacom package. Is the only one that provides it. Also have to reboot after installing it.

If you respected the steps, then this is what you should see in terminal output (depending what kernel you are using):

pamac build digimend-kernel-drivers-dkms-git
Checking digimend-kernel-drivers-dkms-git dependencies...
Resolving dependencies...
Checking inter-conflicts...

To install (1):
  dkms                              2.8.6-2           (Required By: digimend-kernel-drivers-dkms-git)  extra  54,7 kB
To build (1):
  digimend-kernel-drivers-dkms-git  10.r0.gec5c16d-2                                                   AUR

Total download size: 54,7 kB
Total installed size: 177,9 kB

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Download of dkms (2.8.6-2) started                                                               
Download of dkms (2.8.6-2) finished                                                              
Checking keyring...                                                                         [1/1]
Checking integrity...                                                                       [1/1]
Loading packages files...                                                                   [1/1]
Checking file conflicts...                                                                  [1/1]
Checking available disk space...                                                            [1/1]
Installing dkms (2.8.6-2)...                                                                [1/1]
Cloning digimend-kernel-drivers-dkms-git build files...
Generating digimend-kernel-drivers-dkms-git information...

Building digimend-kernel-drivers-dkms-git...
==> Making package: digimend-kernel-drivers-dkms-git 10.r0.gec5c16d-2 (Sb 25 sep 2021 12:13:33 +0300)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning digimend-kernel-drivers git repo...
Cloning into bare repository '/var/tmp/pamac-build-b/digimend-kernel-drivers-dkms-git/digimend-kernel-drivers'...
remote: Enumerating objects: 2027, done.
remote: Counting objects: 100% (128/128), done.
remote: Compressing objects: 100% (94/94), done.
remote: Total 2027 (delta 77), reused 55 (delta 34), pack-reused 1899
Receiving objects: 100% (2027/2027), 607.21 KiB | 4.63 MiB/s, done.
Resolving deltas: 100% (1360/1360), done.
==> Validating source files with md5sums...
    digimend-kernel-drivers ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of digimend-kernel-drivers git repo...
Cloning into 'digimend-kernel-drivers'...
==> Starting pkgver()...
==> Updated version: digimend-kernel-drivers-dkms-git 10.r3.g4762230-1
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "digimend-kernel-drivers-dkms-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: digimend-kernel-drivers-dkms-git 10.r3.g4762230-1 (Sb 25 sep 2021 12:13:37 +0300)
==> Cleaning up...

Checking keyring...                                                                         [1/1]
Checking integrity...                                                                       [1/1]
Loading packages files...                                                                   [1/1]
Checking file conflicts...                                                                  [1/1]
Checking available disk space...                                                            [1/1]
Installing digimend-kernel-drivers-dkms-git (10.r3.g4762230-1)...                           [1/1]
Running post-transaction hooks...
Reloading device manager configuration...                                                   [1/3]
Arming ConditionNeedsUpdate...                                                              [2/3]
Install DKMS modules                                                                        [3/3]
==> dkms install --no-depmod -m digimend-kernel-drivers -v 10.r3.g4762230 -k 5.13.19-2-MANJARO
==> depmod 5.13.19-2-MANJARO
Transaction successfully finished.
1 Like

and reboot, tablet now listed and its input recognised. - Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.